<div dir="ltr"><span class="" style="border-collapse:collapse;font-family:arial,sans-serif;font-size:13px">Thank you kevin for Ur reply. But I don't have <span style="border-collapse:collapse;font-family:'Times New Roman',serif;font-size:16px"><i>barnyard2-master directory and </i></span><span style="border-collapse:collapse;font-family:'Times New Roman',serif;font-size:16px"><i>autogen.sh file in my BY2 directory. Can you provide me with a link from where I can download the version of BY2 containing these files? I am using Ubuntu 12.04. </i></span></span><br>
</div><div class="gmail_extra"><br><br><div class="gmail_quote">On Mon, May 12, 2014 at 8:24 PM, basant subba <span dir="ltr"><<a href="mailto:basantsubba@...11827..." target="_blank">basantsubba@...11827...</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr">Thank you kevin for Ur reply and apologies for mailing you in person. But I don't have <span style="border-collapse:collapse;font-family:'Times New Roman',serif;font-size:16px"><i>barnyard2-master directory and </i></span><span style="border-collapse:collapse;font-family:'Times New Roman',serif;font-size:16px"><i>autogen.sh file in my BY2 directory. Can you provide me with a link from where I can download the version of BY2 containing these files? Thank You </i></span></div>
<div class="HOEnZb"><div class="h5">
<div class="gmail_extra"><br><br><div class="gmail_quote">On Mon, May 12, 2014 at 8:06 PM, Kurzawa, Kevin <span dir="ltr"><<a href="mailto:kkurzawa@...16800..." target="_blank">kkurzawa@...16800...</a>></span> wrote:<br>

<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div lang="EN-US" link="blue" vlink="purple"><div><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d">From an answer I got on a somewhat different topic from Jeremy Hoel. I’m assuming you are using Barnyard2 on CentOS/RedHat/etc. <u></u><u></u></span></p>

<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d"><u></u> <u></u></span></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d"><u></u> <u></u></span></p>

<p class="MsoNormal"><i>As for BY2, you need mysql-devel<u></u><u></u></i></p><p class="MsoNormal"><i><u></u> <u></u></i></p><p class="MsoNormal"><i>cd barnyard2-master<u></u><u></u></i></p><p class="MsoNormal"><i>./autogen.sh<u></u><u></u></i></p>

<p class="MsoNormal"><i>./configure --with-mysql --with-mysql-libraries=/usr/lib64/mysql<u></u><u></u></i></p><p class="MsoNormal"><i>make<u></u><u></u></i></p><p class="MsoNormal"><i>make install<u></u><u></u></i></p><p class="MsoNormal">

<span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d"><u></u> <u></u></span></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d"><u></u> <u></u></span></p>

<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d"><u></u> <u></u></span></p><div style="border:none;border-top:solid #b5c4df 1.0pt;padding:3.0pt 0in 0in 0in">

<p class="MsoNormal"><b><span style="font-size:10.0pt;font-family:"Tahoma","sans-serif"">From:</span></b><span style="font-size:10.0pt;font-family:"Tahoma","sans-serif""> basant subba [mailto:<a href="mailto:basantsubba@...11827..." target="_blank">basantsubba@...11827...</a>] <br>

<b>Sent:</b> Monday, May 12, 2014 9:19 AM<br><b>To:</b> <a href="mailto:snort-users@lists.sourceforge.net" target="_blank">snort-users@...635...eforge.net</a><br><b>Subject:</b> [Snort-users] Baryard2 error<u></u><u></u></span></p>

</div><div><div><p class="MsoNormal"><u></u> <u></u></p><div><p class="MsoNormal">Hello snort users. When I am trying run barnyard to process my unified2 output alerts, I am getting this error.<u></u><u></u></p>
<div><p class="MsoNormal"><u></u> <u></u></p></div><div><div><p class="MsoNormal"><b>database: 'mysql' support is not compiled into this build of snort</b><u></u><u></u></p></div><div><p class="MsoNormal"><u></u> <u></u></p>

</div><div><p class="MsoNormal"><b>ERROR: If this build of snort was obtained as a binary distribution (e.g., rpm,</b><u></u><u></u></p></div><div><p class="MsoNormal"><b>or Windows), then check for alternate builds that contains the necessary</b><u></u><u></u></p>

</div><div><p class="MsoNormal"><b>'mysql' support.</b><u></u><u></u></p></div></div><div><p class="MsoNormal"><u></u> <u></u></p></div><div><p class="MsoNormal"><b>The error is self explanatory in the sense that my installed version of snort doesn't support mqsql. My query is how do I rebuild my snort so that it supports mysql without removing the installed version?</b><u></u><u></u></p>

</div><div><p class="MsoNormal"><u></u> <u></u></p></div></div></div></div></div></div></blockquote></div><br></div>
</div></div></blockquote></div><br></div>