<html xmlns:v="urn:schemas-microsoft-com:vml" xmlns:o="urn:schemas-microsoft-com:office:office" xmlns:w="urn:schemas-microsoft-com:office:word" xmlns:m="http://schemas.microsoft.com/office/2004/12/omml" xmlns="http://www.w3.org/TR/REC-html40"><head><meta http-equiv=Content-Type content="text/html; charset=us-ascii"><meta name=Generator content="Microsoft Word 14 (filtered medium)"><style><!--
/* Font Definitions */
@font-face
        {font-family:Calibri;
        panose-1:2 15 5 2 2 2 4 3 2 4;}
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0in;
        margin-bottom:.0001pt;
        font-size:11.0pt;
        font-family:"Calibri","sans-serif";}
a:link, span.MsoHyperlink
        {mso-style-priority:99;
        color:blue;
        text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
        {mso-style-priority:99;
        color:purple;
        text-decoration:underline;}
span.EmailStyle17
        {mso-style-type:personal-compose;
        font-family:"Calibri","sans-serif";
        color:windowtext;}
.MsoChpDefault
        {mso-style-type:export-only;
        font-family:"Calibri","sans-serif";}
@page WordSection1
        {size:8.5in 11.0in;
        margin:1.0in 1.0in 1.0in 1.0in;}
div.WordSection1
        {page:WordSection1;}
--></style><!--[if gte mso 9]><xml>
<o:shapedefaults v:ext="edit" spidmax="1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
<o:shapelayout v:ext="edit">
<o:idmap v:ext="edit" data="1" />
</o:shapelayout></xml><![endif]--></head><body lang=EN-US link=blue vlink=purple><div class=WordSection1><p class=MsoNormal>I’m getting the following error when I run Pulledpork to update the rules:<o:p></o:p></p><p class=MsoNormal><o:p> </o:p></p><p class=MsoNormal>Error 504 when fetching https://www.snort.org/reg-rules/snortrules-snapshot-2946.tar.gz.md5 at ./pulledpork.pl line 453<o:p></o:p></p><p class=MsoNormal>        main::md5file('ec204f5d939e10bf200423149d081d13688934a9', 'snortrules-snapshot-2946.tar.gz', '/tmp/', 'https://www.snort.org/reg-rules/') called at ./pulledpork.pl line 1758<o:p></o:p></p><p class=MsoNormal><o:p> </o:p></p><p class=MsoNormal>Is anyone else experiencing this?  I’ve used Pulledpork successfully on this Snort sensor many times so this failure is new behavior.  The last time I updated rules, I got a 504 the first time or two but after a few tries, the rules updated successfully.  Today I can’t get past this 504 error.  As you may know, 504 is “Gateway timeout”.  Could this be an issue at Sourcefire or perhaps the path to/from Sourcefire?   A packet from the remote server suggests I do get as far as Sourcefire since the content of the SSL session includes “Maryland”, “Columbia”, and “Sourcefire”.<o:p></o:p></p><p class=MsoNormal><o:p> </o:p></p><p class=MsoNormal>Vern<o:p></o:p></p></div></body></html>