<br><font size=2 face="sans-serif">Sure you have invoked the version you
compiled?</font>
<br><font size=2 face="sans-serif">Did you have a previous 'canned' version?</font>
<br>
<br><font size=2 face="sans-serif">Meaning no insult... this happenned
to me.</font>
<br>
<br><font size=2 face="sans-serif">jacques<br>
---</font>
<br>
<br>
<br>
<table width=100%>
<tr valign=top>
<td width=40%><font size=1 face="sans-serif"><b>james smith <jsmith021961@...131...></b>
</font>
<br><font size=1 face="sans-serif">Sent by: snort-users-admin@lists.sourceforge.net</font>
<p><font size=1 face="sans-serif">02/14/2005 03:35 PM</font>
<td width=59%>
<table width=100%>
<tr valign=top>
<td>
<div align=right><font size=1 face="sans-serif">To</font></div>
<td><font size=1 face="sans-serif">snort-users@lists.sourceforge.net</font>
<tr valign=top>
<td>
<div align=right><font size=1 face="sans-serif">cc</font></div>
<td>
<tr valign=top>
<td>
<div align=right><font size=1 face="sans-serif">Subject</font></div>
<td><font size=1 face="sans-serif">[Snort-users] snort and mysql issues</font></table>
<br>
<table>
<tr valign=top>
<td>
<td></table>
<br></table>
<br>
<br>
<br><font size=2><tt>I recently tried to upgrade a working<br>
snort-2.2.0/mysql/acid installation to a<br>
snort-2.3.0/mysql/base installation.<br>
<br>
mysql version was 4.0.21<br>
<br>
<br>
I moved the previous snort install, config files, etc<br>
and compiled the new snort version by typing:<br>
# ./configure --with-mysql=/usr/local/mysql<br>
# make<br>
# make install<br>
<br>
It worked, and the configure script said:<br>
...<br>
checking for mysql... yes<br>
...<br>
<br>
I then tried to run snort by typing:<br>
# /usr/local/bin/snort -c /etc/snort/snort.conf -i<br>
eth0 -g snort<br>
<br>
I got this error message:<br>
------------------------------------<br>
database: configured to use mysql<br>
database: 'mysql' support is not compiled into this<br>
build of snort<br>
<br>
ERROR: If this build of snort was obtained as a binary<br>
distribution (e.g., rpm,<br>
or Windows), then check for alternate builds that<br>
contains the necessary<br>
'mysql' support.<br>
<br>
If this build of snort was compiled by you, then<br>
re-run the<br>
the ./configure script using the '--with-mysql'<br>
switch.<br>
For non-standard installations of a database, the<br>
'--with-mysql=DIR'<br>
syntax may need to be used to specify the base<br>
directory of the DB install.<br>
<br>
See the database documentation for cursory details<br>
(doc/README.database).<br>
and the URL to the most recent database plugin<br>
documentation.<br>
Fatal Error, Quitting..<br>
----------------------------------<br>
This sucked, so I moved /usr/local/mysql and mysql<br>
config files, etc. and recompiled & installed a brand<br>
new mysql instance of 4.0.21<br>
<br>
Same thing - same error message.<br>
<br>
I'm compiling the latest stable mysql to go with<br>
latest stable snort, but while it's running I figured<br>
I would post here.<br>
<br>
Any tips or hints would be apprciated.<br>
<br>
</tt></font>
<br>