[Snort-users] daq_static library not found

stephan schwebke stephan.schwebke at gmail.com
Mon Nov 27 15:54:11 EST 2017


I'm running Linux Mint 18.1, using Ubuntu 16.04, and am trying to download
snort 2.9.11 from source. It was going fine until I ran ./configure
--enable-sourcefire && make && make install, where I got the error:
"daq_static library not found, go get it from http://www.snort.org." I
looked on the site but cannot find it anywhere. Where would I get it?
Above the error, I also noticed the following, just in case they may have
some bearing:
check whether we are running cross compiling... no
checking if mt is a manifest tool...no
checking if gcc supports -fno-rtti -fno-exceptions...no
checking for dll tool...no
checking for sysroot...no
checking whether byte ordering is bigendian...no
checking /sys/sockio.h presence..no
checking for uuid/uuid.h presensec...no
checking for socket in -lsocket...no
checking for pcap_lex_destroy...no
checking dnet.h presence...no
checking for eth_set in -ldnet
checking for daq_load_modules in -ldaq_static...no
./configure: line 16264: daq-modules-config: command not found
I checked in the manual for snort 2.9.11 and found instructions to do the
following:
ethtool -K eth1 gro off
ethtool -K eth1 lro off
I was able to turn off the gro but, even as administrator, am unable to
turn off lro.
Thank you for any time spent trying to solve this matter.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.snort.org/pipermail/snort-users/attachments/20171127/99ac0adf/attachment.html>


More information about the Snort-users mailing list