[Snort-users] Problem With Dynamic Library

Jim Campbell jim at ...17675...
Mon Jun 12 14:28:11 EDT 2017


I have been running Snort 2.9.8.6 (I believe) and used the cookbook on 
http://sublimerobots.com/2017/01/installing-openappid-with-snort-2-9-9-x-on-ubuntu/ 
to do the upgrade to 2.9.9.0.

I stopped the copy of Snort that was running prior to compiling the new 
version.

When I run the test "sudo snort -T -i enp1s0 -c 
/etc/snort/snort.ips.conf" I get the following error:

ERROR: The dynamic detection library 
"/usr/local/lib/snort_dynamicrules/file-executable.so" version 1.0 
compiled with dynamic engine library version 2.6 isn't compatible with 
the current dynamic engine library 
"/usr/local/lib/snort_dynamicengine/libsf_engine.so" version 3.0.

And yes, I did the "sudo ldconfig" to update the shared libraries.

Any help would be much appreciated.

Jim Campbell

-- 
"We are not human beings having a spiritual experience;
we are spiritual beings having a human experience."
---Pierre Teilhard de Chardin





More information about the Snort-users mailing list