[Snort-users] Question regarding Barnyard2

Y M snort at ...15979...
Sun Jan 15 10:04:56 EST 2017


I "think" you have to also install libmysqlclient-dev or it's equivalent on your distro. I am not on a computer to validate.

YM.
_____________________________
From: Bob Baller <bobballer at ...15978...<mailto:bobballer at ...15978...>>
Sent: Sunday, January 15, 2017 12:32 AM
Subject: [Snort-users] Question regarding Barnyard2
To: <snort-users at lists.sourceforge.net<mailto:snort-users at ...5870....net>>


Hello,  I am having a problem getting Barnyard2 to work.  Snort seems to be working fine but I keep getting the following error when I attempt to run Barnyard:
ERROR database: 'mysql' support is not compiled into this build of barnyard2

ERROR: If this build of barnyard2 was obtained as a binary distribution (e.g., rpm,
or Windows), then check for alternate builds that contains the necessary
'mysql' support.

I've set '--with-MySql' and have reinstalled it many times.  I am clearly missing something

I am running the following

Linux Mint           ver 18 32bit
MySql                   ver 5.7.16-0ubuntu0.16.04.1
Snort                     ver 2.9.7.0-5
Barnyard2           ver 2.1.14 Build 339

I would appreciate any help.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.snort.org/pipermail/snort-users/attachments/20170115/58ef90be/attachment.html>


More information about the Snort-users mailing list