[Snort-users] Not able to compile pfring-daq-module in PF_RING 6.4.1

fatema bannatwala fatema.bannatwala at ...11827...
Wed Nov 30 18:24:39 EST 2016


Hmm so this worked:
$ ./configure CPPFLAGS=-I/usr/local/daq/2.0.6/include
<snip>
checking daq_api.h usability... yes
checking daq_api.h presence... yes
checking for daq_api.h... yes
checking sfbpf.h usability... yes
checking sfbpf.h presence... yes
checking for sfbpf.h... yes
checking for sfbpf_compile in -lsfbpf... no
configure: error: Could not link against the SFBPF library!

But now getting SFBPF library error :(
*The never ending loop of errors..Sigh* ;)

On Wed, Nov 30, 2016 at 6:19 PM, Marcin Dulak <marcin.dulak at ...11827...>
wrote:

> Maybe,
> CPPFLAGS='-I/usr/local/daq/2.0.6/include' ./configure
>
> Marcin
>
> On Thu, Dec 1, 2016 at 12:16 AM, fatema bannatwala <
> fatema.bannatwala at ...11827...> wrote:
>
>> Hi Marcin,
>>
>> Thanks for the suggestions.
>> I have daq_api.h in the daq/2.0.6 folder, hence tried using that.
>>
>> I did:
>>
>> [~]$ locate daq_api.h
>> /usr/local/daq/2.0.6/include/daq_api.h
>>
>> [~pfring-daq-module]$ ./configure CPPFLAGS =
>> '-I/usr/local/daq/2.0.6/include'
>> configure: WARNING: you should use --build, --host, --target
>> configure: error: invalid variable name: `'
>>
>> And getting error invalid variable name.
>>
>> Did I miss something here?
>>
>> Thanks,
>> Fatema.
>>
>>
>> On Wed, Nov 30, 2016 at 6:08 PM, Marcin Dulak <marcin.dulak at ...11827...>
>> wrote:
>>
>>> Hi,
>>>
>>> cd /tmp
>>> wget https://www.snort.org/downloads/snort/daq-2.0.6-1.centos7.x8
>>> 6_64.rpm
>>> rpm -qpl daq-2.0.6-1.centos7.x86_64.rpm | grep 'daq_api.h'
>>> /usr/include/daq_api.h
>>>
>>> Maybe the easiest way is to go with this daq RPM which will put
>>> daq_api.h into the default include path.
>>> Otherwise search
>>> find /usr/local/daq/2.0.6 -name daq_api.h
>>> and provide this include path, possibly with CPPFLAGS = '-I
>>> /usr/local/daq/2.0.6/include'
>>>
>>> Marcin
>>>
>>>
>>> On Wed, Nov 30, 2016 at 11:44 PM, fatema bannatwala <
>>> fatema.bannatwala at ...11827...> wrote:
>>>
>>>> Hi,
>>>>
>>>> I am trying to make snort work with the latest PF_RING 6.4.1, hence
>>>> started with the install of different modules comes with pf_ring tar file.
>>>> I successfully installed kernel, userland/lib, userland/libpcap and
>>>> userland/tcpdump.
>>>> But when trying to configure userland/snort/pfring-daq-module getting
>>>> consistent error:
>>>>
>>>> [~pfring-daq-module]$ ./configure
>>>>  <snip>
>>>> checking CFLAGS for gcc -Wformat... -Wformat
>>>> checking CFLAGS for gcc -Wformat-security... -Wformat-security
>>>> checking CFLAGS for gcc -Wno-unused-parameter... -Wno-unused-parameter
>>>> checking CFLAGS for gcc -fno-strict-aliasing... -fno-strict-aliasing
>>>> checking CFLAGS for gcc -fdiagnostics-show-option...
>>>> -fdiagnostics-show-option
>>>> checking CFLAGS for gcc -pedantic -std=c99 -D_GNU_SOURCE... -pedantic
>>>> -std=c99 -D_GNU_SOURCE
>>>> checking daq_api.h usability... no
>>>> checking daq_api.h presence... no
>>>> checking for daq_api.h... no
>>>> configure: error: Could not find daq_api.h!
>>>>
>>>> I am not able to figure out why it is not able to find daq_api.h, or do
>>>> I have to copy it from somewhere in some directory?
>>>>
>>>> Also, After installing various modules of pf ring (except
>>>> pfring-daq-module) I installed daq-2.0.6
>>>> as well, which successfully got configured and installed.
>>>> [ ~/daq-2.0.6]$ ./configure --prefix=/usr/local/daq/2.0.6
>>>> --with-libpcap-includes=/usr/local/pfring/6.4.1/include
>>>> --with-libpcap-libraries=/usr/local/pfring/6.4.1/lib
>>>> --with-dnet-includes=/usr/local/libdnet/include
>>>> --with-dnet-libraries=/usr/local/libdnet/lib
>>>> --with-libpfring-includes=/usr/local/pfring/6.4.1/include
>>>> --with-libpfring-libraries=/usr/local/pfring/6.4.1/lib LIBS=-lpthread
>>>>
>>>> After installing daq module I again tried installing pfring-daq-module
>>>> from PF_RING pakage, but same error.
>>>> Running CentOS7
>>>>
>>>> Any help appreciated.
>>>>
>>>> Thanks,
>>>> Fatema.
>>>>
>>>>
>>>> ------------------------------------------------------------
>>>> ------------------
>>>>
>>>> _______________________________________________
>>>> Snort-users mailing list
>>>> Snort-users at lists.sourceforge.net
>>>> Go to this URL to change user options or unsubscribe:
>>>> https://lists.sourceforge.net/lists/listinfo/snort-users
>>>> Snort-users list archive:
>>>> http://sourceforge.net/mailarchive/forum.php?forum_name=snort-users
>>>>
>>>> Please visit http://blog.snort.org to stay current on all the latest
>>>> Snort news!
>>>>
>>>
>>>
>>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.snort.org/pipermail/snort-users/attachments/20161130/68295f8e/attachment.html>


More information about the Snort-users mailing list