[Snort-users] RHEL 6.7 dnet library not found - but is there

Ehardt, Laurie J (IS) Laurie.Ehardt at ...9374...
Wed Apr 27 18:51:25 EDT 2016


I have a similar issue with installing on RHEL 6.7 with a few changes to the output.

Re: CentOS install 6.2 - dnet library not found - but is there
________________________________





On Sun, Apr 8, 2012 at 5:56 PM, Hanks, Dustin <hokorippoi () gmail com> wrote:

When trying to ./configure Snort I get this:

.....

checking dnet.h usability... no

checking dnet.h presence... no

checking for dnet.h... no

checking dumbnet.h usability... no

checking dumbnet.h presence... no

checking for dumbnet.h... no



   ERROR!  dnet library not found, go get it from

   http://code.google.com/p/libdnet/ or use the --with-dnet-*

   options, if you have it installed in an unusual place





dnet is there:

# dnet-config --libs --cflags --version

1.12

-I/usr/local/include

-L/usr/local/lib -ldnet



# /usr/local/lib

lib/     lib64/   libexec/





I have tried:

# ./configure --with-dnet-libraries=/usr/local/lib/

--with-dnet-includes=/usr/local/include/



Still get error.




I tried this but linked to the libdnet.so actually copied the libraries to the directories and did not work.


From: Jeremy Hoel <jthoel () gmail com>
Date: Mon, 9 Apr 2012 20:56:01 +0000

________________________________

When I'm building dnet on a 64bit system I end up linking it..



cd /usr/src

tar -xzvf libdnet-1.11.tar.gz

cd libdnet-1.11

./configure && make && make install

ln -s /usr/local/lib/libdnet.1 /usr/lib/

ln -s /usr/local/lib/libdnet.1 /usr/lib64/



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.snort.org/pipermail/snort-users/attachments/20160427/16404269/attachment.html>


More information about the Snort-users mailing list