[Snort-users] Error with LuaJIT when compiling 2.9.7.x on OS X with OpenAppID

Wil Mail willstmail at ...11827...
Fri May 29 17:59:03 EDT 2015


Hi,
Well, this is fun.  I started picking apart the configure script again to
figure out which pkg-config commands it was running.  I then realized I
didn't have pkg-config installed at all, which was actually evidenced in
the script output.  Just before the "checking for luajit... no" line, it
also said "checking for pkg-config... no".  Further, grepping for
PKG_CONFIG variables in config.log shows that PKG_CONFIG and
PKG_CONFIG_LIBDIR were empty.  I installed pkg-config via brew, reran my
configure script with options, and voila.  It configures and compiles just
fine!

To further validate, I uninstalled pkg-config, reran configure, and it
failed as expected.

Moral of the story - pkg-config is required for the configure script on OS
X, at least when enabling OpenAppID.

Thanks for the prompting to check on pkg-config.


For future reference, this was what my reply was GOING to be before I did
that one last configure after installing pkg-config:

"""
I believe this means that pkgconfig can find LuaJIT:

$ pkg-config --libs luajit
-L/usr/local/lib -lluajit-5.1

And

$ pkg-config --list-all | grep -i lua
lua5.2               Lua - An Extensible Extension Language
lua-5.2              Lua - An Extensible Extension Language
luajit               LuaJIT - Just-in-time compiler for Lua
lua                  Lua - An Extensible Extension Language


If I'm pulling the right lines from configure script, I think this also
means yes it can find LuaJIT:

$ pkg-config --print-errors --cflags --libs luajit
-I/usr/local/include/luajit-2.0 -L/usr/local/lib -lluajit-5.1
"""






On Fri, May 29, 2015 at 10:01 AM, Carter Waxman (cwaxman) <cwaxman at ...589...
> wrote:

>  Hi Wil,
>
>  Does pkgconfig find LuaJIT when run manually?
>
>  Thanks,
> Carter
>
>   From: Wil Mail <willstmail at ...11827...>
> Date: Wednesday, May 27, 2015 at 10:18 AM
> To: snort-users <snort-users at lists.sourceforge.net>
> Subject: Re: [Snort-users] Error with LuaJIT when compiling 2.9.7.x on OS
> X with OpenAppID
>
>   Hi,
> I posted this a few weeks ago and I don't think I saw any response.  I
> just tried again with 2.9.7.3 on OS X 10.9, but same result.  I don't see a
> new version of LuaJIT.  Is anyone rolling Snort on OS X with OpenAppID
> configured?
>
>
> On Fri, May 8, 2015 at 5:12 PM, Wil Mail <willstmail at ...11827...> wrote:
>
>> Hello,
>> I've been trying to compile 2.9.7 and 2.9.7.2 on OS X 10.9, using these
>> configure options:
>>
>>  ./configure --prefix=/opt/snort --enable-sourcefire --enable-open-appid
>>
>>  I consistently fail on LuaJIT:
>>
>>  checking for luajit... no
>>
>>     ERROR!  LuaJIT library not found. For better performance, go get it
>> from
>>    http://www.luajit.org/.
>> configure: error: "Fatal!"
>>
>>
>>  My config.log shows luajit_CFLAGS and luajit_LIBS set to empty.  I've
>> tried installing LuaJIT two ways, first by following the suggestion of
>> downloading from luajit.org and then through brew.  In the former
>> option, I downloaded LuaJIT 2.0.3 tarball, ran a 'make' followed by 'sudo
>> make install.'  That reports a successful install to /usr/local.  In the
>> latter option, I just did a 'brew install luajit', which claims to have
>> successfully installed luajit-2.0.3_1.
>>
>>  I have a luajit.pc file in /usr/local/lib/pkgconfig, and if I read it
>> correctly it maps includedir and libdir to places where libluajit and .h
>> files exist.  My user account running the configure has rights to read all
>> of those directories and files.
>>
>>  Snort configure fails I've done a fresh install from source, brew, or
>> both at the same time.  I've also tried running the configure with sudo
>> just for fun.
>>
>>  Any ideas what's wrong here?
>>
>>
>>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.snort.org/pipermail/snort-users/attachments/20150529/c4fbf401/attachment.html>


More information about the Snort-users mailing list