[Snort-users] Baryard2 error

Kurzawa, Kevin kkurzawa at ...16800...
Mon May 12 10:36:08 EDT 2014


From an answer I got on a somewhat different topic from Jeremy Hoel. I’m assuming you are using Barnyard2 on CentOS/RedHat/etc.


As for BY2, you need mysql-devel

cd barnyard2-master
./autogen.sh
./configure --with-mysql --with-mysql-libraries=/usr/lib64/mysql
make
make install



From: basant subba [mailto:basantsubba at ...11827...]
Sent: Monday, May 12, 2014 9:19 AM
To: snort-users at lists.sourceforge.net
Subject: [Snort-users] Baryard2 error

Hello snort users. When I am trying run barnyard to process my unified2 output alerts, I am getting this error.

database: 'mysql' support is not compiled into this build of snort

ERROR: If this build of snort was obtained as a binary distribution (e.g., rpm,
or Windows), then check for alternate builds that contains the necessary
'mysql' support.

The error is self explanatory in the sense that my installed version of snort doesn't support mqsql. My query is how do I rebuild my snort so that it supports mysql without removing the installed version?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.snort.org/pipermail/snort-users/attachments/20140512/52f8ebd2/attachment.html>


More information about the Snort-users mailing list