[Snort-users] Problems Enabling IPQ and NFQ

MMartin at ...16693... MMartin at ...16693...
Fri Mar 7 15:50:37 EST 2014


So I used the zypper command and searched for the libnetfilter and I have 
the following packages installed, see below...

The packages listed below that are preceeded with an 'i' are installed... 
Do I have the correct ones? 
I'm running on 64-bit so I didn't download the ones labeled with 32 bit.

# zypper search libnetfilter
        Loading repository data...
        Reading installed packages...
        --+---------------------------------------------
        i | libnetfilter_acct-devel
        i | libnetfilter_acct1
          | libnetfilter_acct1-32bit
        i | libnetfilter_conntrack-devel
        i | libnetfilter_conntrack3
          | libnetfilter_conntrack3-32bit
        i | libnetfilter_cthelper-devel
        i | libnetfilter_cthelper0
          | libnetfilter_cthelper0-32bit
        i | libnetfilter_cttimeout-devel
        i | libnetfilter_cttimeout1
          | libnetfilter_cttimeout1-32bit
        i | libnetfilter_log-devel
        i | libnetfilter_log1
          | libnetfilter_log1-32bit
        i | libnetfilter_queue-devel
        i | libnetfilter_queue1
          | libnetfilter_queue1-32bit


# zypper search libnfnetlink
        Loading repository data...
        Reading installed packages...

        S | Name
        --+-----------------------------
        i | libnfnetlink-devel
        i | libnfnetlink0
        i | libnfnetlink0-32bit



Those are the correct packages, right?

I also searched on my machine for libipq and found the following (*I 
searched within the /usr dir...):

snortIDS:/usr # find ./ -iname "*ipq*"
        ./include/iptables-1.4.16.3/libipq.h
        ./local/src/daq-2.0.2/os-daq-modules/daq_ipq.c
 
./local/src/daq-2.0.2/os-daq-modules/.deps/libdaq_static_modules_la-daq_ipq.Plo
        ./local/src/daq-2.0.2/os-daq-modules/.deps/daq_ipq_la-daq_ipq.Plo
        ./local/lib64/daq/daq_ipq.so
        ./local/lib64/daq/libipq.so
        ./local/lib64/libipq.so.0
        ./local/lib64/libipq.so 
        ./local/lib64/libipq.so.0.0.0
        ./lib64/pkgconfig/libipq.pc
        ./lib64/libipq.so.0
        ./lib64/libipq.so
        ./lib64/libipq.so.0.0.0


I feel like I do have everything and maybe DAQ just isn't finding it...?

Thanks Again,
Matt

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.snort.org/pipermail/snort-users/attachments/20140307/a33040a4/attachment.html>


More information about the Snort-users mailing list