[Snort-users] Snort appears to be successfully compiled, but I cannot run it.

Gee Zany krimpton11 at ...15979...
Mon Jan 20 09:42:05 EST 2014

Okay I guess I found out the reason why. Snort, when compiled from source, is not detected as a program by the command 'which' .
I have to cd to /usr/local/snort/bin and execute './snort' instead.  The first execution has some errors which were solved by 'sudo ldconfig' . 
I have another query though, is snort.conf supposed to be manually created by ourselves ? 
From: krimpton11 at ...15979...
To: snort-users at lists.sourceforge.net
Date: Sun, 19 Jan 2014 15:26:28 +0100
Subject: [Snort-users] Snort appears to be successfully compiled,	but I cannot run it.

I followed the steps in this PDF http://www.snort.org/assets/158/snortinstallguide293.pdf for my installation of Snort on my LinuxMint OS. 
Had huge trouble with libdnet, but it finally got solved with "apt-get install libdumbnet-dev" . Could this be the cause ? Anyway, it allowed me to continue with the daq installation.. 
When I entered ' which snort' in terminal, nothing appeared. 
But doing a 'locate snort' lists many directories in which snort can be found.. 
Examples are :
I am really at a loss at what to do now. Any help is greatly appreciated. 


CenturyLink Cloud: The Leader in Enterprise Cloud Services.
Learn Why More Businesses Are Choosing CenturyLink Cloud For
Critical Workloads, Development Environments & Everything In Between.
Get a Quote or Start a Free Trial Today.
Snort-users mailing list
Snort-users at lists.sourceforge.net
Go to this URL to change user options or unsubscribe:
Snort-users list archive:

Please visit http://blog.snort.org to stay current on all the latest Snort news! 		 	   		  
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.snort.org/pipermail/snort-users/attachments/20140120/53ebbe84/attachment.html>

More information about the Snort-users mailing list