[Snort-users] snort-2.9.6.0-1.x86_64.rpm :: libdnet present but requires

Adrian Sevcenco Adrian.Sevcenco at ...16656...
Mon Apr 21 04:58:22 EDT 2014


Hi! I try to install (update) snort from an build by me rpm
snort-2.9.5.6-1.x86_64 to the snort.org supplied snort-2.9.6.0-1.x86_64.rpm.
(Centos 6.5 x86_64)

The problem:
Examining snort-2.9.6.0-1.x86_64.rpm: 1:snort-2.9.6.0-1.x86_64
Marking snort-2.9.6.0-1.x86_64.rpm as an update to 1:snort-2.9.5.6-1.x86_64
Resolving Dependencies
--> Running transaction check
---> Package snort.x86_64 1:2.9.5.6-1 will be updated
---> Package snort.x86_64 1:2.9.6.0-1 will be an update
--> Processing Dependency: libdnet.1()(64bit) for package:
1:snort-2.9.6.0-1.x86_64
--> Finished Dependency Resolution
Error: Package: 1:snort-2.9.6.0-1.x86_64 (/snort-2.9.6.0-1.x86_64)
           Requires: libdnet.1()(64bit)
           Available: libdnet-1.11-1.2.el6.rf.x86_64 (rpmforge)
               libdnet.1()(64bit)
           Installed: libdnet-1.12-6.el6.x86_64 (@epel)
               Not found
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

but:
[root at ...16806... rpms]# rpm -qa libdnet libdnet-devel
libdnet-1.12-6.el6.x86_64
libdnet-devel-1.12-6.el6.x86_64

[root at ...16806... rpms]# locate libdnet.
/usr/lib64/libdnet.so
/usr/lib64/libdnet.so.1
/usr/lib64/libdnet.so.1.0.1

Does anyone have an idea about the problem?

Thanks a lot!!
Adrian




More information about the Snort-users mailing list