[Snort-users] First time snorting ... ERROR: The dynamic detection library ...

waldo kitty wkitty42 at ...14940...
Thu Nov 14 12:02:35 EST 2013


On 11/14/2013 11:35 AM, Alan McKay wrote:
> ERROR: The dynamic detection library
> "/usr/local/snort/lib/snort_dynamicrules/netbios.so" version 1.0
> compiled with dynamic engine library version 2.0 isn't compatible with
> the current dynamic engine library
> "/usr/local/snort/lib/snort_dynamicengine/libsf_engine.so" version
> 2.1.

this not loading has nothing to do with you using a precompiled SO... it states 
the reason it is not loading fairly clearly, if tersely...

netbios.so [...] compiled with [...] library version 2.0 isn't compatible with 
[...] libsf_engine.so version 2.1

so basically, your netbios.so file is too old to be used with your current snort 
which is using libsf_engine v2.1...

you said you are using snort 2.9.5.5... what rules pack are you using??

-- 
NOTE: No off-list assistance is given without prior approval.
       Please keep mailing list traffic on the list unless
       private contact is specifically requested and granted.




More information about the Snort-users mailing list