[Snort-users] Snort Libpcap Error During Installation

Snort User snort.user123 at ...11827...
Fri Jun 28 08:41:49 EDT 2013


I am trying to install snort-2.9.4.6 on Redhat 6.3 i386 but am getting the
following error


ERROR!  Libpcap library/headers (libpcap.a (or .so)/pcap.h)

   not found, go get it from http://www.tcpdump.org

   or use the --with-libpcap-* options, if you have it installed

   in unusual place.  Also check if your libpcap depends on another

   shared library that may be installed in an unusual place



I have uninstalled the redhat libpcap that I had installed with yum and
compiled my own libpcap 1.4.0. The libpcap was the latest version from
tcpdump.org, not the development version.



The following files are located in /usr/local/lib

-rw-r--r--. 1 root root 754998 Jun 27 08:14 libpcap.a

lrwxrwxrwx. 1 root root     12 Jun 27 08:14 libpcap.so -> libpcap.so.1

lrwxrwxrwx. 1 root root     16 Jun 27 08:14 libpcap.so.1 -> libpcap.so.1.4.0

-rwxr-xr-x. 1 root root 552966 Jun 27 08:14 libpcap.so.1.4.0



The following files are located in /usr/local/include.

drwxr-xr-x. 2 root root 4096 Jun 27 08:14 pcap

-rw-r--r--. 1 root root 2393 Jun 27 08:14 pcap-bpf.h

-rw-r--r--. 1 root root 2320 Jun 27 08:14 pcap.h

-rw-r--r--. 1 root root 2125 Jun 27 08:14 pcap-namedb.h



I tried running like this:

./configure --with-libpcap-libraries=/usr/local/lib
--with-libpcap-libraries=/usr/local/include



I also tried adding to ldconfig.



Yet I’m still getting the libpcap error and I don’t know why.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.snort.org/pipermail/snort-users/attachments/20130628/597466e7/attachment.html>


More information about the Snort-users mailing list