[Snort-users] PF_RING and DAQ compile (0.6.2, and 2.0.0)

Avery Rozar Avery.Rozar at ...16118...
Thu Jun 27 12:51:51 EDT 2013


The original error was on a KVM VM. I was using eth1:eth2 and got that
error. I moved it to the host, and am now using eth2:eth3 and got the same
error but it did state "eth2". I just copied the original error for the
post, that¹s why eth1 is in it. No matter what interface I use, I get the
same error.

On 6/27/13 12:04 PM, "waldo kitty" <wkitty42 at ...14940...> wrote:

>On 6/27/2013 11:02, Avery Rozar wrote:
>> Thank you for your answer Tim, I can only assume that you answered my
>> first question on the Meteflows group. I'm getting an error "FATAL
>>ERROR:
>> Can't start DAQ (-1) - pfring_open(): unable to open device 'eth1'.
>>Please
>
>eth1...
>
>> use -i<device>!" when I try to start snort using pfring. I thought maybe
>> is was due to the DAQ compile error. I moved snort off the VM, and on
>>the
>> physical host, and disabled selinux. I still get the same error. Would
>>it
>> be due to the default bnx2 driver, or pfring license issue? Any help is
>> greatly appreciated.
>>
>>
>> ethtool -i eth2
>
>eth2...  not the same as above... why? ;)
>
>> driver: bnx2
>> version: 2.2.3
>> firmware-version: bc 1.9.6
>> bus-info: 0000:0f:04.0
>> supports-statistics: yes
>> supports-test: yes
>> supports-eeprom-access: yes
>> supports-register-dump: yes
>> supports-priv-flags: no
>
>
>
>-- 
>NOTE: No off-list assistance is given without prior approval.
>       Please keep mailing list traffic on the list unless
>       private contact is specifically requested and granted.
>
>--------------------------------------------------------------------------
>----
>This SF.net email is sponsored by Windows:
>
>Build for Windows Store.
>
>http://p.sf.net/sfu/windows-dev2dev
>_______________________________________________
>Snort-users mailing list
>Snort-users at lists.sourceforge.net
>Go to this URL to change user options or unsubscribe:
>https://lists.sourceforge.net/lists/listinfo/snort-users
>Snort-users list archive:
>http://sourceforge.net/mailarchive/forum.php?forum_name=snort-users
>
>Please visit http://blog.snort.org to stay current on all the latest
>Snort news!





More information about the Snort-users mailing list