[Snort-users] @barnyard2 error

anagha b banagha3 at ...11827...
Thu Jul 11 04:19:19 EDT 2013


Hi all


At the time of install i installed snort for user anagha.
If i run snort as root then snort starts packet processing but if i try to
run snort other than root [as anagh]i get following error
anagha at ...15657...~$  snort -c /srv/cloud/one/snort-2.9.4.6/etc/snort.conf -i
eth0
Initializing Output Plugins!
pcap DAQ configured to passive.
Acquiring network traffic from "eth0".
ERROR: Can't start DAQ (-1) - socket: Operation not permitted!
Fatal Error, Quitting..


I tried to start barnyard when* snort is running with root* but i
configured databases access for specific user[I set this user for snort
already] for barnyard  i am getting error for barnyard when i run snort as
root.

barnyard2 -c /srv/cloud/one/barnyard2-2-1.13/etc/barnyard2.conf -f snort.u2
-w /var/log/snort/barnyard2.waldo

error:Barnyard2 spooler: Event cache size set to [2048]
Log directory = /var/log/snort/
INFO database: Defaulting Reconnect/Transaction Error limit to 10
INFO database: Defaulting Reconnect sleep time to 5 second
database mysql_error: Access denied for user 'root'@'localhost' (using
password: YES)
Barnyard2 exiting
database: Closing connection to database "db"





plz help .
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.snort.org/pipermail/snort-users/attachments/20130711/ba4d809b/attachment.html>


More information about the Snort-users mailing list