[Snort-users] Unable to use dynamicrules on CentOS 6.4 x86_64

Jaspal jaspal at ...16427...
Fri Jul 5 05:47:34 EDT 2013


Hi,

I am trying to use the dynamic rules present in 
snort-rules-snapshot-2495 with snort-2.9.5 on a CentOS 6.4 x86_64 Amazon 
EC2 VM.
I have compiled daq and snort from source. Used libdnet and 
libdnet-devel from the rpm repo.

I get the following error upon trying to use the precompiled shared libs 
from either of RHEL-6.0 or CentOS-5.4 :
"The dynamic detection library 
"/usr/local/lib/snort_dynamicrules/web-activex.so" version 1.0 compiled 
with dynamic engine library version 1.17 isn't compatible with the 
current dynamic engine library 
"/usr/local/lib/snort_dynamicengine/libsf_engine.so" version 2.0"

Both the snort-rules and snort are compiled from the latest sources.
It looks like a version mismatch. But where exactly ?
Or is there a way to compile the shared libs and use them ?
Also, why does snort provide precompiled shared libs for CentOS-6.x ?

Thanks,
Jaspal
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.snort.org/pipermail/snort-users/attachments/20130705/0b026e4e/attachment.html>


More information about the Snort-users mailing list