[Snort-users] compiling error

waldo kitty wkitty42 at ...14940...
Sun Apr 28 20:15:39 EDT 2013


On 4/28/2013 18:56, Balla István wrote:
> Hello,
>
> After issuing the sudo /usr/local/snort/bin/snort -u snort -g snort -c
> /usr/local/snort/etc/snort.conf -i eth1 command I get the following error message:
>
> ERROR: The dynamic detection library
> "/usr/local/snort/lib/snort_dynamicrules/web-activex.so" version 1.0 compiled
> with dynamic engine library version 1.17 isn't compatible with the current
> dynamic engine library
> "/usr/local/snort/lib/snort_dynamicengine/libsf_engine.so" version 1.16.
> Fatal Error, Quitting..
>
> Could you advise hw to fix it?

as the error message states, that SO rule file is not compatible with the 
current dynamic engine library... your only options are to update your SO rules 
to the current library version *OR* delete/disable them in your snort.conf...

-- 
NOTE: No off-list assistance is given without prior approval.
       Please keep mailing list traffic on the list unless
       private contact is specifically requested and granted.




More information about the Snort-users mailing list