[Snort-users] Errors installing SNORT 2.9 to SuSE Linux 12.2 - rpm or tar.gz

Kurt Jensen CISSP kjensencissp at ...11827...
Mon Apr 1 09:56:08 EDT 2013


Hi, I hope everyone had a great weekend and holiday! Any thoughts or ideas on the Snort install and setup (make) related errors I ran into yet I posted back on March 22nd?  

 

It has been a long time since I ever installed and ran Snort it seemed like it should have worked out using the documentation and tips you offer for SuSE users.  Yet I am sad to say that between two different images of SuSE Linux (one is a 12.2 VM with KDE, and another 12.2 that was upgraded from 11.x as a native install) I was not able to get a successful install and initialization going yet.  I would like to get it running and learn from the experience too.  Might the error information below lead to answers?  Thoughts?  I am new to this online community so my apologies if somehow I missed a reply.

 

Lars

 

From: Joel Esler [mailto:jesler at ...1935...] 
Sent: Friday, March 22, 2013 8:34 PM
To: Kurt Jensen CISSP
Cc: <snort-users at lists.sourceforge.net>
Subject: Re: [Snort-users] Errors installing SNORT 2.9 to SuSE Linux 12.2 - rpm or tar.gz

 

Can you copy and paste the commands you are typing and the errors you are getting?

--

Joel Esler

Sent from my iPhone 


On Mar 22, 2013, at 5:35 PM, "Kurt Jensen CISSP" <kjensencissp at ...11827...> wrote:

Hello Group,

 

I have been attempting to install the latest rpm OR .tar.gz of SNORT to my fairly plain test instance of SuSE 12.2 I use for student work and testing of what I know, other tools etc.  The system is an i386 32bit Toshiba laptop booting directly into SuSE 12.2, and the trouble is with Snort installation.

 

Here is what is happening that I could definitely use help with:

 

While in the case of the .tar.gz version the “configure phase” worked fine once I had all the pre-install required dependency connected libraries and packages, and finished as far as I can tell w/o errors.  Yet when I try to run make it refers to a number of directories it enters and exits with an error saying for example “there is nothing to do for all” and then “make[5] there is no rule to build” etc.  I have been researching this a lot and come up with no direct answers.  My GUESS is it is looking for a rule package but I have not been able to find a free one yet to download if that is the problem. I am a student on this and do not wish to buy any rules, I can just use the most basic ones out there as I get started and was surprised to find it seems none are included to start out with and finish an install?

 

“rpm” method:  When I downloaded and tried installing the rpm version instead using SuSE YaST software manager/install tool (GUI) the process begins but always errors out saying it failed/cannot complete with the error “nothing provides libcrypto.so.10” but my SUSE install has SSH and several GNU and/or other crypto libraries I just added (with source/development libraries) yet none of these work?

 

Any assistance is greatly appreciated and what am I missing?

 

Lars Jensen

------------------------------------------------------------------------------
Everyone hates slow websites. So do we.
Make your web apps faster with AppDynamics
Download AppDynamics Lite for free today:
http://p.sf.net/sfu/appdyn_d2d_mar

_______________________________________________
Snort-users mailing list
Snort-users at lists.sourceforge.net
Go to this URL to change user options or unsubscribe:
https://lists.sourceforge.net/lists/listinfo/snort-users
Snort-users list archive:
http://sourceforge.net/mailarchive/forum.php?forum_name=snort-users

Please visit http://blog.snort.org to stay current on all the latest Snort news!

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.snort.org/pipermail/snort-users/attachments/20130401/ec097f33/attachment.html>


More information about the Snort-users mailing list