[Snort-users] Snort 2.9.2.3 not logging

Naresh Narang nnarang at ...15655...
Tue May 29 11:13:06 EDT 2012


So I found out that logging is not happening in this newer version until there is an event. If I scan ports using nmap it does log. Since I was used to seeing huge logging in older version I thought it wasn't working.

Also, to correct my earlier statement about "config order", it does take effect.

I just wish that development folks try to compile this on Solaris at least once.

--Naresh
Sent from my iPhone

On May 29, 2012, at 8:05 AM, "Joel Esler" <jesler at ...1935...<mailto:jesler at ...1935...>> wrote:

A reject would still be logged.  The action just happens first.

Joel

On May 28, 2012, at 1:12 PM, Naresh Narang <nnarang at ...15655...<mailto:nnarang at ...15655...>> wrote:

Here is a difference I found in “config order” between version 2.8.3 and 2.9.2.3 –

Before upgrade:

May 18 07:27:55 dc1infra01 snort[12293]: [ID 702911 daemon.notice] Rule application order: activation->dynamic->pass->drop->alert->log

After upgrade:

May 27 00:10:38 dc1infra01 snort[7021]: [ID 702911 daemon.notice] Rule application order: activation->dynamic->pass->drop->sdrop->reject->alert->log

It seems that if snort doesn’t have any “alert” it would get dropped by “reject” and hence not get logged. I tried to change config order to the way it was before –

config order: activation dynamic pass drop alert log


in snort.conf but the change did not take effect.


--Naresh

From: Naresh Narang [mailto:nnarang at ...15655...<http://guardiananalytics.com>]
Sent: Sunday, May 27, 2012 9:17 AM
To: snort-users at lists.sourceforge.net<mailto:snort-users at lists.sourceforge.net>
Subject: [Snort-users] Snort 2.9.2.3 not logging

Hi all,

               I compiled latest version of Snort 2.9.2.3 with all the related software (daq etc.) on Solaris X86. Its running fine with no errors but is not logging anything to files. Files get created with epoch time stamp but stay at 0 bytes. Any ideas? If I run from command line, with –L option, I can log to files just fine. Snort.conf is same as it was before from ver 2.8.3, which was logging fine.


$ snort -V

   ,,_     -*> Snort! <*-
  o"  )~   Version 2.9.2.3 IPv6 GRE (Build 205)
   ''''    By Martin Roesch & The Snort Team: http://www.snort.org/snort/snort-team
           Copyright (C) 1998-2012 Sourcefire, Inc., et al.
           Using libpcap version 1.1.1
           Using PCRE version: 8.30 2012-02-04
           Using ZLIB version: 1.2.3

Running in IDS mode:

snort[7030]: [ID 702911 daemon.notice]
snort[7030]: [ID 702911 daemon.notice]         --== Initialization Complete ==--
snort[7030]: [ID 702911 daemon.notice] Commencing packet processing (pid=7030)

barnyard2[8402]: [ID 702911 daemon.notice] Opened spool file '/var/log/snort/snort.u2.1338102640'
barnyard2[8402]: [ID 702911 daemon.notice] Waiting for new data


Thanks,


--Naresh

------------------------------------------------------------------------------
Live Security Virtual Conference
Exclusive live event will cover all the ways today's security and
threat landscape has changed and how IT managers can respond. Discussions
will include endpoint security, mobile security and the latest in malware
threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/_______________________________________________
Snort-users mailing list
Snort-users at lists.sourceforge.net<mailto:Snort-users at lists.sourceforge.net>
Go to this URL to change user options or unsubscribe:
https://lists.sourceforge.net/lists/listinfo/snort-users
Snort-users list archive:
http://www.geocrawler.com/redir-sf.php3?list=snort-users

Please visit http://blog.snort.org to stay current on all the latest Snort news!

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.snort.org/pipermail/snort-users/attachments/20120529/4fbe11a0/attachment.html>


More information about the Snort-users mailing list