[Snort-users] Snort 2.8->2.9 upgrade, DAQ and libpcap

Weir, Jason jason.weir at ...14916...
Fri May 18 09:28:12 EDT 2012


Pretty straight forward...

Install libpcap:

# wget http://www.tcpdump.org/release/libpcap-1.2.1.tar.gz
# tar -zxf  libpcap-1.2.1.tar.gz && cd libpcap-1.2.1
# ./configure --prefix=/usr --enable-shared && make && make install

-J

> -----Original Message-----
> From: Joel Esler [mailto:jesler at ...1935...]
> Sent: Friday, May 18, 2012 9:20 AM
> To: Maurizio Molina
> Cc: snort-users at lists.sourceforge.net
> Subject: Re: [Snort-users] Snort 2.8->2.9 upgrade, DAQ and libpcap
> 
> As noted in the blog post you reference below:
> 
> PCAP ≥ 1.0.0. PCAP 1.1.1 is available at the time of this writing and
> is recommended.
> 
> So..  Yes.  You'll need to download, compile, and install libpcap 1.0.0
> or higher.
> 
> Joel
> 
> On May 18, 2012, at 1:46 AM, Maurizio Molina wrote:
> 
> > Hi,
> > I'm trying to upgrade from 2.8 to 2.9.2.3, and I'm getting this error
> >
> > checking for dlsym in -ldl... yes
> > ./configure: line 15188: daq-modules-config: command not found
> > checking for daq_load_modules in -ldaq_static... no
> >
> >    ERROR! daq_static library not found, go get it from
> >    http://www.snort.org/.
> > make: *** [snort_configure] Error 1
> >
> > and from what I read here:
> > http://vrt-blog.snort.org/2010/08/snort-29-essentials-daq.html
> > pcap > 1.0.0 is required. I am still running pcap 0.9.8
> >
> > Can somebody confirm that I can't continue working with the old pcap
> > version?
> >
> > Thanks,
> > Maurizio Molina



_____________________________________________________________________________________________

Please visit www.nhrs.org to subscribe to NHRS email announcements and updates.


More information about the Snort-users mailing list