[Snort-users] Cannot build 2.9.2.2 on OpenBSD 5.0

Olaf Schreck chakl at ...931...
Thu Mar 29 17:44:14 EDT 2012


Hi Chris, sorry for the late reply..

On Thu, Mar 29, 2012 at 08:29:07PM +0000, Chris Eidem wrote:
> I've been attempting to build snort on OpenBSD 5.0 for a couple of weeks now and with the release of 2.9.2.2 I thought that my luck may change.  Nope.

> ERROR: parser.c(5302) Could not stat dynamic module path "/usr/local/lib/snort_dynamicengine/libsf_engine.so": No such file or directory.
> Fatal Error, Quitting..

> ./snort_dynamicengine:
> libsf_engine.a  libsf_engine.la

> Questions:
> - why are there no shared objects?

Been there, worked around that on a pre-OpenBSD-5.0 system.  I don't 
remember what the exact problem was.

Have a close look on the build log around "libsf_engine" or in config.log 
files, there was a clue..

I *think* it was related to GNU autohell making assumptions that didn't 
work out.  And this one smells similar:

> >From the output of make for snort:
> *** Warning: This system can not link to static lib archive /usr/local/lib/libdaq_static.la.

Did you explicitly define the AUTOCONF_VERSION, AUTOMAKE_VERSION etc 
environment variables?

> I have the output from the make and make install if they'd be of use.

Feel free to contact me privately, snort on OpenBSD 5.0 is on my todo list.


ciao,
chakl




More information about the Snort-users mailing list