[Snort-users] Compiling Snort and Razorback Error

Jonathan S. Abrams jonathansabrams at ...11827...
Sun Feb 5 23:54:08 EST 2012


I am trying to install Snort v2.9.2.1 on OS X Server v10.6.8 and I am
running into the same problem with Razorback.  The fix for v10.4.11 was to
install pkg-config 0.23.  I installed pkg-config 0.25 on OS X Server
v10.6.8 and I am still having this problem.

Does anyone reading this know what could be the problem this time?

On Mon, Jan 9, 2012 at 10:04 AM, Russ Combs <rcombs at ...1935...> wrote:

> OK great.  We'll try to fix the configure foo to be smarter about that
> condition.
>
>
> On Fri, Jan 6, 2012 at 8:26 PM, Jonathan S. Abrams <
> jonathansabrams at ...11827...> wrote:
>
>> I finally figured out what was causing this error.  I did some googling
>> on less than the entire error message and eventually found this.
>>
>> http://myitcorner.com/blog/?p=207
>>
>> This tipped me off that pkg-config was not installed by either Apple or
>> myself in this OS X installation.  I installed pkg-config 0.23 and then
>> successfully installed Snort.
>>
>> Should there be a note in the docs that Mac OS X users may need to
>> install pkg-config?
>>
>> Thanks for your input!
>>
>> On Thu, Jan 5, 2012 at 9:32 PM, Russ Combs <rcombs at ...1935...> wrote:
>>
>>> None of them require razorback.  I checked on FC14 but the configure foo
>>> for this is not OS specific.  However, I'll try it on OS X tomorrow.
>>>
>>>
>>> On Thu, Jan 5, 2012 at 8:02 PM, Jonathan S. Abrams <
>>> jonathansabrams at ...11827...> wrote:
>>>
>>>> Yes, I was using the tarball from snort.org.  I downloaded the one you
>>>> linked to, and while I did not get an error about the --disable-rzb-saac
>>>> option for ./configure, I still get the original error I reported.
>>>>
>>>> ./configure: line 32359: syntax error near unexpected token `RAZORBACK,'
>>>> ./configure: line 32359: `    PKG_CHECK_MODULES(RAZORBACK, razorback >=
>>>> 0.1.3, , LRZB=no)'
>>>>
>>>> What OS did you check this on?  Is there a version of snort pre-2.9.2
>>>> that does not require Razorback at all (no need for --disable-rzb-saac)?
>>>>
>>>> On Thu, Jan 5, 2012 at 10:48 AM, Russ Combs <rcombs at ...1935...>wrote:
>>>>
>>>>> Are you using the tarball off snort.org (snort-2.9.2.tar.gz<http://www.snort.org/downloads/1347>
>>>>> )?
>>>>>
>>>>> Just downloaded to double check and that option works as it should.
>>>>>
>>>>>
>>>>> On Wed, Jan 4, 2012 at 8:36 PM, Jonathan S. Abrams <
>>>>> jonathansabrams at ...11827...> wrote:
>>>>>
>>>>>> When I executed ./configure --disable-static-daq --disable-rzb-saac,
>>>>>> I received this error.
>>>>>> --
>>>>>> configure: WARNING: Unrecognized options: --disable-rzb-saac
>>>>>> --
>>>>>> ./configure then proceeded until it got to this point
>>>>>> --
>>>>>> config.status: executing depfiles commands
>>>>>> configure: WARNING: Unrecognized options: --disable-rzb-saac
>>>>>> --
>>>>>> Here's the output of 'head config.log'
>>>>>> --
>>>>>> This file contains any messages produced by compilers while
>>>>>> running configure, to aid debugging if configure makes a mistake.
>>>>>>
>>>>>> It was created by configure, which was
>>>>>> generated by GNU Autoconf 2.62.  Invocation command line was
>>>>>>
>>>>>>   $ ./configure --disable-static-daq --disable-rzb-saac
>>>>>>
>>>>>> ## --------- ##
>>>>>> ## Platform. ##
>>>>>> --
>>>>>>
>>>>>> Thanks for your suggestions.  Any ideas for what to try next?
>>>>>>
>>>>>> On Wed, Jan 4, 2012 at 10:13 AM, Russ Combs <rcombs at ...1935...>wrote:
>>>>>>
>>>>>>> Hmmm.  Can you send `head config.log`?
>>>>>>>
>>>>>>> To explicitly disable razorback from the Snort build, use:
>>>>>>>
>>>>>>> ./configure --disable-rzb-saac
>>>>>>>
>>>>>>>
>>>>>>> On Tue, Jan 3, 2012 at 10:00 PM, Jonathan S. Abrams <
>>>>>>> jonathansabrams at ...11827...> wrote:
>>>>>>>
>>>>>>>> Thanks for responding.  Here are the commands I am using, in order
>>>>>>>> of execution.
>>>>>>>>
>>>>>>>> glibtoolize --force
>>>>>>>> aclocal -I m4
>>>>>>>> autoheader
>>>>>>>> automake --add-missing --copy
>>>>>>>> autoconf
>>>>>>>> set LD_TWOLEVEL_NAMESPACE=1 (my shell is tcsh, that is why I am not
>>>>>>>> using export here)
>>>>>>>> ./configure --disable-static-daq
>>>>>>>>
>>>>>>>> These commands result in the error in my original post.  When I
>>>>>>>> execute ./configure --help, the manual that appears claims that I can type
>>>>>>>> --without-PACKAGE to not use a package.  I then tried this command
>>>>>>>>
>>>>>>>> ./configure --disable-static-daq --without-RAZORBACK
>>>>>>>>
>>>>>>>> which resulted in the following message.
>>>>>>>>
>>>>>>>> configure: WARNING: UNRECOGNIZED OPTIONS:  --without-RAZORBACK
>>>>>>>>
>>>>>>>> I tried the same command using rzb instead of razorback and
>>>>>>>> received the same error.
>>>>>>>>
>>>>>>>> I opened up the configure.in file, and there is a chunk of code
>>>>>>>> from line 1524 through line 1560 for rzb-saac, but I am not certain how
>>>>>>>> this is implicated.
>>>>>>>>
>>>>>>>> Any further guidance is appreciated.  Thanks for your assistance!
>>>>>>>>
>>>>>>>> On Tue, Jan 3, 2012 at 11:46 AM, Russ Combs <rcombs at ...1935...>wrote:
>>>>>>>>
>>>>>>>>> Check your configure options.  It looks like you may
>>>>>>>>> have --enable-rzb-saac.
>>>>>>>>>
>>>>>>>>>  On Mon, Jan 2, 2012 at 9:04 AM, Jonathan S. Abrams <
>>>>>>>>> jonathansabrams at ...11827...> wrote:
>>>>>>>>>
>>>>>>>>>> Hello,
>>>>>>>>>>
>>>>>>>>>> I am trying to compile Snort v2.9.2 on OS X v10.4.11, and I am
>>>>>>>>>> close to getting it done.  I am receiving an error during ./configure make
>>>>>>>>>> that I am hoping someone can help me with.
>>>>>>>>>>
>>>>>>>>>> ./configure: line 32359: syntax error near unexpected token
>>>>>>>>>> `RAZORBACK,'
>>>>>>>>>> ./configure: line 32359: `    PKG_CHECK_MODULES(RAZORBACK,
>>>>>>>>>> razorback >= 0.1.3, , LRZB=no)'
>>>>>>>>>>
>>>>>>>>>> I thought razorback was optional, as it's not listed at
>>>>>>>>>> http://www.snort.org/start/requirements.  Is that not the case?
>>>>>>>>>>  If it is optional, what do I need to change so that this error does not
>>>>>>>>>> occur?
>>>>>>>>>>
>>>>>>>>>> Thanks for reading!
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> ------------------------------------------------------------------------------
>>>>>>>>>> Write once. Port to many.
>>>>>>>>>> Get the SDK and tools to simplify cross-platform app development.
>>>>>>>>>> Create
>>>>>>>>>> new or port existing apps to sell to consumers worldwide. Explore
>>>>>>>>>> the
>>>>>>>>>> Intel AppUpSM program developer opportunity.
>>>>>>>>>> appdeveloper.intel.com/join
>>>>>>>>>> http://p.sf.net/sfu/intel-appdev
>>>>>>>>>> _______________________________________________
>>>>>>>>>> Snort-users mailing list
>>>>>>>>>> Snort-users at lists.sourceforge.net
>>>>>>>>>> Go to this URL to change user options or unsubscribe:
>>>>>>>>>> https://lists.sourceforge.net/lists/listinfo/snort-users
>>>>>>>>>> Snort-users list archive:
>>>>>>>>>> http://www.geocrawler.com/redir-sf.php3?list=snort-users
>>>>>>>>>>
>>>>>>>>>> Please visit http://blog.snort.org to stay current on all the
>>>>>>>>>> latest Snort news!
>>>>>>>>>
>>>>>>>>>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.snort.org/pipermail/snort-users/attachments/20120205/4acaa84c/attachment.html>


More information about the Snort-users mailing list