[Snort-users] Barnyard2 giving issues after upgrading system

beenph beenph at ...11827...
Fri Aug 17 08:24:03 EDT 2012


On Fri, Aug 17, 2012 at 8:17 AM, Pratik Narang
<pratik.cse.bits at ...11827...> wrote:
> Well i am not sure if this one is fit for Snort-users or Ubuntu-users,
> but here goes...
>
> Ever since i upgraded to Ubuntu 12.04, i started getting some issues
> with Snort and Barnyard2, one of them being this-
>
> As I do-
> sudo /usr/local/bin/barnyard2 -c /usr/local/snort/etc/barnyard2.conf
> -d /var/log/snort -f test1.u2 -w /var/log/snort/barnyard2.waldo
>
> I get-
> /usr/local/bin/barnyard2: error while loading shared libraries:
> libmysqlclient.so.16: cannot open shared object file: No such file or
> directory
>
Seem's like it can't find libmysql, which probably implies that the
barnyard2 you have is compiled with mysql support.

You might want to check for that shared lib on your system else you
might want to try to install the appropriate package
that comes with your distro that contain the file or compile mysql for
your plateform and that should install he missing libs.

-elz




More information about the Snort-users mailing list