[Snort-users] daq_static with 2.9.1

Hatim Alghamdi hat_gh at ...131...
Tue Jun 28 10:12:55 EDT 2011


This is part of the config.log

configure:14142: checking for daq_load_modules in -ldaq_static
configure:14167: gcc -o conftest -g -O2   -DDYNAMIC_PLUGIN -I/usr/include  -lpcre -L/usr/lib64 -ldnet -L/usr/include conftest.c -ldaq_static   -ldnet -lpcre -lpcap -lnsl -lm -lm  
-ldl -L/usr/lib -ldaq_static_modules  -lsfbpf -lpcap -lsfbpf -lpcap >&5
/usr/bin/ld: skipping incompatible /usr/lib/libdaq_static.a when searching for -ldaq_static
/usr/bin/ld: skipping incompatible /usr/lib/libdaq_static.a when searching for -ldaq_static
/usr/bin/ld: cannot find -ldaq_static
collect2: ld returned 1 exit status


----- Original Message -----
From: Martin Holste <mcholste at ...11827...>
To: Hatim Alghamdi <hat_gh at ...131...>
Cc: "snort-users at lists.sourceforge.net" <snort-users at lists.sourceforge.net>
Sent: Tuesday, June 28, 2011 4:54 PM
Subject: Re: [Snort-users] daq_static with 2.9.1

Ok, what's the last error in your config.log?

On Tue, Jun 28, 2011 at 8:30 AM, Hatim Alghamdi <hat_gh at ...131...> wrote:
> I do have them
>
>>ls -l libdaq*
> -rw-r--r-- 1 root root 11934 Jun  8 05:25 libdaq.a
> -rwxr-xr-x 1 root root   935 Jun  8 05:25 libdaq.la
> lrwxrwxrwx 1 root root    15 Jun 28 15:53 libdaq.so -> libdaq.so.0.0.1
> lrwxrwxrwx 1 root root    15 Jun 28 15:53 libdaq.so.0 -> libdaq.so.0.0.1
> -rwxr-xr-x 1 root root 33510 Jun  8 05:25 libdaq.so.0.0.1
> -rw-r--r-- 1 root root 12472 Jun  8 05:25 libdaq_static.a
> -rwxr-xr-x 1 root root   903 Jun  8 05:25 libdaq_static.la
> -rw-r--r-- 1 root root 31330 Jun  8 05:25 libdaq_static_modules.a
> -rwxr-xr-x 1 root root   927 Jun  8 05:25 libdaq_static_modules.la
>
>
> ----- Original Message -----
> From: Martin Holste <mcholste at ...11827...>
> To: Hatim Alghamdi <hat_gh at ...131...>
> Cc: "snort-users at lists.sourceforge.net" <snort-users at ...3893...t>
> Sent: Tuesday, June 28, 2011 4:21 PM
> Subject: Re: [Snort-users] daq_static with 2.9.1
>
> You should have a bunch of libdaq_static.* files in /usr/lib as well,
> specifically, a libdaq_static.a, libdaq_static.la, and others.  What
> do you have for /usr/lib/libdaq* ?
>
> On Tue, Jun 28, 2011 at 7:46 AM, Hatim Alghamdi <hat_gh at ...131...> wrote:
>> Hi all,
>>
>> I reached a dead end with compiling snort 2.9.1. I know many faced the same issue and I tried many of the suggestions but still couldn't solve it.
>>
>> checking for daq_load_modules in -ldaq_static... no
>>
>>    ERROR!  daq_static library not found, go get it from
>>
>> I read that I've to make sure I've daq-modules-config in my path and it is.
>>
>> few commands I'm including which mentioned in the posts I saw.
>>
>>>daq-modules-config --static --libs
>> -L/usr/lib -ldaq_static_modules  -lsfbpf -lpcap -lsfbpf -lpcap
>>
>>>nm /usr/lib/libdaq_static.a | grep daq_load_modules
>> 00000000000008e0 T daq_load_modules
>>
>>>ldconfig -p | grep daq
>> libdaq.so.0 (libc6) => /usr/lib/libdaq.so.0
>> libdaq.so (libc6) => /usr/lib/libdaq.so
>>
>> I appreciate your help.
>>
>> Thanks in advance.
>>
>> Regards,
>> Hatim
>>
>> ------------------------------------------------------------------------------
>> All of the data generated in your IT infrastructure is seriously valuable.
>> Why? It contains a definitive record of application performance, security
>> threats, fraudulent activity, and more. Splunk takes this data and makes
>> sense of it. IT sense. And common sense.
>> http://p.sf.net/sfu/splunk-d2d-c2
>> _______________________________________________
>> Snort-users mailing list
>> Snort-users at lists.sourceforge.net
>> Go to this URL to change user options or unsubscribe:
>> https://lists.sourceforge.net/lists/listinfo/snort-users
>> Snort-users list archive:
>> http://www.geocrawler.com/redir-sf.php3?list=snort-users
>>
>> Please see http://www.snort.org/docs for documentation
>>
>
>





More information about the Snort-users mailing list