[Snort-users] Barnyard2 compile error (angry platypus)

firnsy firnsy at ...14568...
Fri Jul 8 21:34:50 EDT 2011


On 08/07/11 01:20, Lay, James wrote:
> Heh...no sooner do I send this, 1.10 Beta 1 comes out and fixes the issue...NICE.
>

Very Nice!

- firnsy


>
>> -----Original Message-----
>> From: Lay, James [mailto:james.lay at ...15009...]
>> Sent: Thursday, July 07, 2011 9:12 AM
>> To: snort-users at lists.sourceforge.net
>> Subject: [Snort-users] Barnyard2 compile error (angry platypus)
>>
>> Topic says it....on Ubuntu...:
>>
>> gcc -DHAVE_CONFIG_H -I. -I../.. -I.. -I ../sfutil  -DSUP_IP6 -DGRE -
>> I/usr/include/mysql -DENABLE_MYSQL  -g -O2 -fno-strict-aliasing -Wall -c
>> spo_platypus.c
>> spo_platypus.c: In function âPlatypusâ:
>> spo_platypus.c:301:36: error: âUnified2IDSEvent6_legacyâ undeclared (first
>> use in this function)
>> spo_platypus.c:301:36: note: each undeclared identifier is reported only
>> once for each function it appears in
>> spo_platypus.c:301:62: error: expected expression before â)â token
>> spo_platypus.c:302:62: error: expected expression before â)â token
>> spo_platypus.c:306:17: error: expected expression before â)â token
>> spo_platypus.c:308:17: error: expected expression before â)â token
>> spo_platypus.c:309:45: error: expected expression before â)â token
>> make[3]: *** [spo_platypus.o] Error 1
>> make[3]: Leaving directory `/home/snortstuff/barnyard2-1.9/src/output-
>> plugins'
>> make[2]: *** [all-recursive] Error 1
>> make[2]: Leaving directory `/home/snortstuff/barnyard2-1.9/src'
>> make[1]: *** [all-recursive] Error 1
>> make[1]: Leaving directory `/home/snortstuff/barnyard2-1.9'
>> make: *** [all] Error 2
>>
>> Any hints on this?
>>
>> James
>>





More information about the Snort-users mailing list