[Snort-users] pulled pork error

Nigel Houghton nhoughton at ...1935...
Sun Feb 13 17:48:44 EST 2011


On Sat, 12 Feb 2011 23:11:22 -0800, Alan Ptak wrote:
> Michael,
> 
> It looks to me like you need to install the LWP::UserAgent perl 
> module on your system. There are several options, including using 
> CPAN. 
> 
> HTH .. Alan
> 
> --
> Alan Ptak
> 310.488.8606
> 
> On Feb 12, 2011, at 8:28 PM, Michael Lubinski 
> <michael.lubinski at ...11827...> wrote:
> 
> 
>> when I launch pulled pork with;
>> 
>> /etc/snort/pulledpork.pl -c /etc/snort/pulledpork.conf -v
>> 
>> I get an error stating
>> 
>> 
>> "can't locate object method "show_progress" via package 
>> "LWP::UserAgent" at /etc/snort/pulledpork.pl line 1323
>> 
>> line 1323 = $ua->show_progress(1) if $Verbose;
>> 
>> Any proficient programmers out there know how to resolve?

You may also have an old version of LWP::UserAgent installed, so using 
cpan to update is also a way to go. Additionally, you can run a Perl 
script like this "perl -cw pulledpork.pl" to see what else (if 
anything) you might be missing and what errors might be there.

Usually, most folks run cpan on the cli and install modules from there, 
if you already have cpan set up you can do this to install without 
using the cpan shell: perl -MCPAN -e 'install LWP::UserAgent' (as root 
normally, to install system wide)

--
Nigel Houghton
Head Mentalist
SF VRT Department of Intelligence Excellence
http://vrt-blog.snort.org/ && http://labs.snort.org/




More information about the Snort-users mailing list