[Snort-users] Snort 2.9.0 packages for RHEL?

Ryan Jordan ryan.jordan at ...1935...
Mon Oct 18 12:07:51 EDT 2010


Hello Olivier, responses inline:

On Mon, Oct 18, 2010 at 9:54 AM, Olivier Bilodeau <obilodeau at ...13341...> wrote:
> Hi,
>
> Do you guys plan to release RPMs for snort 2.9.0 on RedHat Enterprise
> Linux 5.0?

No. Snort 2.9.0 and the DAQ library rely on libpcap version 1.0 or
above, but RHEL 5 only supplies libpcap 0.9. As a result, we are
unable to provide RPMs that will install on RHEL 5. Red Hat's
"rawhide" distribution contains libpcap 1.0, so I would expect this
problem to be solved when RHEL 6 is released.

> If not, is there something in your modified GPL license that would
> prevent us from hosting a yum repo for that?

Snort is still GPL, you can modify and redistribute to your heart's
content. You will also need to repackage libpcap 1.0+ for RHEL 5,
hopefully in such a way that it doesn't break apps which depend on
libpcap 0.9.

-Ryan




More information about the Snort-users mailing list