[Snort-users] DAQ and libpcap 1.1.1 vs 1.0.0

vincent at ...15035... vincent at ...15035...
Mon Nov 8 11:41:59 EST 2010


On Mon, 8 Nov 2010, Mike Lococo wrote:

> Vincent,
>
> Thanks the the pointer, I had actually looked at your repo but in a fit
> of absent-mindedness didn't think to check for srpms (I need to rebuild
> libpcap with DAG-support enabled, so most binary RPMS don't help me).
> I'll have a peak.

I just updated the 'repo' with my latest test builds. libpcap-1.1.1 is 
back and compiled with --disable-remote (this seems to prevent daq from 
crashing)

> Some subsequent testing suggests maybe there's just some library
> search-path issues going on, but I haven't figured out what
> libpcap-1.0.0 vs 1.1.1 do differently in that regard.  Will report back
> once I've got it sorted, I had just hoped someone else had done the work
> for me.

Look into this srpm, it might be of some help. That's how I got snort 
working with libpcap-1.1.1 on rhel5.. (--disable-remote)
http://vscojot.free.fr/dist/snort/RHEL5/SRPMS/libpcap1-1.1.1-7.el5.src.rpm

I hope this helps,

Vincent




More information about the Snort-users mailing list