[Snort-users] zlib and 2.8.6 problem on Ubuntu 8.04

John York YorkJ at ...7109...
Tue May 11 10:23:15 EDT 2010


I'm having trouble upgrading from 2.8.5.3 to 2.8.6.  Snort errors out,
ERROR: /usr/local/etc/snort/snort.conf(200) => Invalid keyword 'compress_depth' for 'global' configuration.

I found the earlier thread suggesting adding --enable-zlib to the ./configure command, which I did.  I still have the same problem.  The output from configure shows, in part:
checking zlib.h usability... no
checking zlib.h presence... no
checking for zlib.h... no

Ubuntu has zlibg1, not good enough I guess.  So, I installed zlib-1.2.5 into the default location /usr/local/zlib.  The same problem remains in both configure and snort.  I tried adding zlib to the path, no luck.  I can get snort to run be commenting out compress_depth, decompress_depth and inspect_gzip from the http preprocessor statements, but it would be good to get it fixed.

Where should I install zlib so that configure can find it, or how do I tell configure where to find zlib?

Thanks
John





More information about the Snort-users mailing list