[Snort-users] upgrade problems 2.5.2 to 2.8.6

Crook, Parker Parker_Crook at ...14786...
Tue Jun 22 15:05:17 EDT 2010


Ah yes, sorry I forgot to notate my 'upgrade' and so I'm going off the cuff here with what I did.  But I believe I just copied from:

<path to snort-2.8.6>/src/dynamic-preprocessors/build/usr/local/lib/snort_dynamicpreprocessor

To

/usr/local/lib/



So, for me:

cp -r /usr/src/snort-2.8.6/src/dynamic-preprocessors/build/usr/local/lib/snort_dynamicpreprocessor /usr/local/lib





-Parker



  _____

From: aanderson at ...14903... [mailto:aanderson at ...14903...]
Sent: Tuesday, June 22, 2010 2:53 PM
To: snort-users at lists.sourceforge.net
Subject: Re: [Snort-users] upgrade problems 2.5.2 to 2.8.6



Due to the same type of thing ...  failures loading various preprocessor libs etc..



that is what I tried too...  now I have the error described (poorly) below.  Currently I have no snort_* directories in /usr/local/lib and am getting the following error: (which makes sense)



ERROR: parser.c(5161) Could not stat dynamic module path "/usr/local/lib/snort_dynamicpreprocessor/": No such file or directory.



What I don't know how to do is force a rebuild of these directories on the install.



From: Crook, Parker [mailto:Parker_Crook at ...14786...]
Sent: Tuesday, June 22, 2010 11:42 AM
To: Andy Anderson
Cc: <snort-users at lists.sourceforge.net>
Subject: RE: [Snort-users] upgrade problems 2.5.2 to 2.8.6



Definitely specific errors would help.  However, if you are looking for general tips or advice, I recall when I upgraded from the 2.8.5.3 build to 2.8.6 I ran make clean && make dist clean from my old 2.8.5.3 source folder.  Then I removed all of the snort_* folders from /usr/local/lib due to a version conflict of the preproc rules... I think my technique may have been a bit brutish, but it worked.



-Parker



  _____

From: JJ Cummings [mailto:cummingsj at ...11827...]
Sent: Tuesday, June 22, 2010 1:21 PM
To: <aanderson at ...14903...>
Cc: <snort-users at lists.sourceforge.net>
Subject: Re: [Snort-users] upgrade problems 2.5.2 to 2.8.6



The specific error(s) that you are receiving would be useful here...

Sent from the iRoad


On Jun 22, 2010, at 11:02, <aanderson at ...14903...<mailto:aanderson at ...14905......>> wrote:

I have upgraded to 2.8.6 from 2.5.2



It appears I have all kinds of problems with preprocessors.



I am installing from  snort-2.8.6.tar.gz



I cannot get it to rebuild the dynamic_preprocessor libraries to /usr/local/lib....



I expect if I can get this to work I will have what I need.  Anyone have suggestions?





------------------------------------------------------------------------------
ThinkGeek and WIRED's GeekDad team up for the Ultimate
GeekDad Father's Day Giveaway. ONE MASSIVE PRIZE to the
lucky parental unit.  See the prize list and enter to win:
http://p.sf.net/sfu/thinkgeek-promo

_______________________________________________
Snort-users mailing list
Snort-users at lists.sourceforge.net<mailto:Snort-users at lists.sourceforge.net>
Go to this URL to change user options or unsubscribe:
https://lists.sourceforge.net/lists/listinfo/snort-users
Snort-users list archive:
http://www.geocrawler.com/redir-sf.php3?list=snort-users

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.snort.org/pipermail/snort-users/attachments/20100622/5c276a8b/attachment.html>


More information about the Snort-users mailing list