[Snort-users] getting "CGI error" while doing snort installation on windows 2003

Sadanand Ghagare sadanandgh at ...11827...
Mon Jan 25 13:31:47 EST 2010


Hi Alexander,

I tried your steps, now when I try to access test.php threw browser it
gives blnak page and not shows any CGI error.
Did this mean its successful, can you share any test PHP file which I
can try with my configuration?


Regards,
Sadanand

On Wed, Jan 20, 2010 at 8:20 PM, Alexander Novokhatsky
<alex.ontario at ...11827...> wrote:
> Hello Sadanand,
>
> http://php.net/downloads.php
> Just tested this PHP 5.12 installer
> During the installation I have both "IIS FastCGI" and "IIS CGI". I've
> chosen the second option and didn't install FastCGI
>
>
> Wednesday, January 20, 2010, 6:33:08 PM, you wrote:
>
>> Hi Alexander,
>
>> WHile reinstalling php-5.2.12-Win32 and try to choose FAST IIS CGI(as
>> there is no otpion called IIS CGI), it asks me download and install
>> fast CGI for IIS.
>> Do I need ti install it?
>
>> REgards,
>> Sadanand
>
>> On Tue, Jan 19, 2010 at 5:40 PM, Alexander Novokhatsky
>> <alex.ontario at ...11827...> wrote:
>>> Hello Sadanand,
>>>
>>> If you haven't performed these steps I'd recommend to reinstall PHP:
>>>> Install PHP:
>>>> Choose IIS CGI
>>>> Directory: C:\PHP
>>>> Include Script Executable, GD2, MSSQL(met twice) and PEAR Support.
>>>
>>> I configured these options during the installation process.
>>> Otherwise you can skip this step and do only necessary settings in
>>> IIS starting with "Creating Virtual Directory for BASE" (or whatever
>>> web-interface you are using)
>>>
>>> Tuesday, January 19, 2010, 5:21:42 PM, you wrote:
>>>
>>>> Thanks Alexander for replying..
>>>> I have installed php-5.2.12-Win32 version already installed.
>>>> Please tell me from where I can change the configuration?
>>>> Or do I need to reinstall it again?
>>>
>>>> Regards,
>>>> Sadanand
>>>
>>>> 2010/1/19 Alexander Novokhatsky <alex.ontario at ...11827...>:
>>>>> Hello Sadanand,
>>>>> Here are the steps I performed. Maybe I'll help.
>>>>>
>>>>> Install PHP:
>>>>>
>>>>> Download PHP from: http://windows.php.net/download/
>>>>> V 2.x  thread safe(Because v3.0 has no mssql support and doesn’t work)
>>>>>
>>>>> Install PHP:
>>>>> Choose IIS CGI
>>>>> Directory: C:\PHP
>>>>> Include Script Executable, GD2, MSSQL(met twice) and PEAR Support.
>>>>>
>>>>> Modify php.ini
>>>>> Max_execution_time=60 (from 30)
>>>>>
>>>>> Reboot
>>>>>
>>>>> Create Virtual Directory for BASE:
>>>>> Start ->Control panel-> Administrative Tools->Internet Information Services (IIS) Manager
>>>>> Expand Web sites
>>>>> Right mouse button on Default Web Site-> New->Virtual Directory…
>>>>> Alias: base
>>>>> Path:  C:\base
>>>>> Check read and run (run should be removed after installation process)
>>>>> (It’s possible to grant access only from specific locations)
>>>>>
>>>>> Right mouse button on Default Web Site-> New->Virtual Directory…
>>>>> Alias: baselog
>>>>> Path:  C:\baselog
>>>>> Check read and run
>>>>>
>>>>> Add PHP extension:
>>>>>
>>>>> Choose “Default Web Site”
>>>>> Right mouse button it->Properties
>>>>> Then Home Directory
>>>>> Click Configuration…
>>>>> If there is no .php extension do following:
>>>>> Click Add…
>>>>> Select path to php.exe file (“C:/PHP/php_cgi.exe”)
>>>>> Extension: .php
>>>>> Script engine should be checked
>>>>>
>>>>> Click the name of your computer then click "Web Service Extensions", on the left side of the main frame you will see a green arrow pointing to a link that says "Add a new Web service extension...", click that link.
>>>>> For the Extension name put something like "PHP" in and for the Required Files put "C:\Program Files\php\php_cgi.exe", also check to set it to allowed
>>>>>
>>>>>
>>>>>
>>>>> Tuesday, January 19, 2010, 4:24:46 PM, you wrote:
>>>>>
>>>>>> I am trying to install snort on windows 2003 with sql 2000 SP4 and
>>>>>> IIS. I am doing installation from steps given by Michael E. Steele
>>>>>
>>>>>> I am done till "Configure IIS for PHP" step, but while doing "Test the
>>>>>> IIS and PHP install" step, I get CGI error when try to access winids/test.php
>>>>>
>>>>>> anybody has any idea about this issue?
>>>>>
>>>>>> Regards,
>>>>>> Sadanand
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>> --
>>>>> Best regards,
>>>>>  Alexander                            mailto:alex.ontario at ...11827...
>>>>>
>>>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>> --
>>> Best regards,
>>>  Alexander                            mailto:alex.ontario at ...11827...
>>>
>>>
>
>
>
>
>
>
> --
> Best regards,
>  Alexander                            mailto:alex.ontario at ...11827...
>
>



-- 


Thanks & Regards

Sadanand G.




More information about the Snort-users mailing list