[Snort-users] Cannot get Snort to generate a core file at segfault

Andy Berryman aberryman at ...14758...
Thu Feb 4 09:54:23 EST 2010


I have a box that is segfaulting multiple times a day. I can't get it to generate a core file when it does though.

It's running 2.8.5.2 and kernel is Linux version 2.6.29.6-20100112 (dave at ...14761...) (gcc version 4.2.4 (Ubuntu 4.2.4-1ubuntu4)) #20 SMP Tue Jan 12 10:22:28 CST 2010
2GB Ram and a Intel Core 2 CPU

I've tried the command "ulimit  -c 1000000" and then "ulimit -c unlimited" and neither has worked.

This is the error I'm getting in syslog when it happens.
 (none) kernel: snort24318<https://forums.snort.org/forums/snort-advanced/topics/can-t-get-snort-to-create-a-core-file-when-it-segfault#fn24318>: segfault at a ip 08079700 sp bfd7c128 error 4 in snort[8048000+a1000]
(none) kernel: device eth1 left promiscuous mode

I do a search of my file systems with "find / -name '*core*' and nothing comes back resembling a core dump.

Any ideas of what I'm doing wrong?

Thanks,
Andy Berryman


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.snort.org/pipermail/snort-users/attachments/20100204/992b1cf5/attachment.html>


More information about the Snort-users mailing list