[Snort-users] Snort 2.9 & DAQ Issues (daq_static)

Korodev korodev at ...11827...
Wed Aug 18 13:02:03 EDT 2010


Having an issue with the latest 2.9 Beta and DAQ on FreeBSD 8.1. I
have downloaded the DAQ source, configured, compiled, and installed ok
with no errors but when I try to install snort I get the following
error:

> checking for daq_load_modules in -ldaq_static... no
>
>    ERROR!  daq_static library not found, go get it from
>    http://www.snort.org/.
>

I confirmed the DAQ libraries and includes are in their appropriate
location and even passed them manually to snort with no avail. I ended
up getting snort to compile by configuring with --disable-static-daq.
Once compiled I'm unable to start snort unless I give it
--daq-dir=/usr/local/lib/daq. Otherwise it complains about not being
able to find the pcap DAQ.

Any help/feedback is much appreciated :)

\\korodev




More information about the Snort-users mailing list