[Snort-users] Segmentation fault

waldo kitty wkitty42 at ...14940...
Tue Aug 3 17:52:38 EDT 2010


On 8/3/2010 05:22, ll wrote:
> ok,now ,just change like that :
>
> Using 2.8.6 snort.conf file.
> I removed the following from /usr/local/lib/snort_dynamicpreprocessor
> directory and it got rid of the error.

this is because you have to remove the old dynamic compiled preprocessors... 
we've have seen it when we have had clients backlevel their snort for some 
reason and left newer preprocessor and .so rules in place... you can also see it 
if you have a newer snort and older so rules...

so, yes, using the proper rules versions for your snort version is very important...

>
> lib_sfdynamic_preprocessor_example.a
> lib_sfdynamic_preprocessor_example.la
> lib_sfdynamic_preprocessor_example.so
> lib_sfdynamic_preprocessor_example.so.0
> lib_sfdynamic_preprocessor_example.so.0.0.0
>
> http://forums.snort.org/forums/support/topics/can-t-start-snort-2-8-6-with-segmentation-fault-error?page=1
>
> 于 2010-8-3 17:09, ll 写道:
>> today ,I upgrade the snort rulesset to the last
>> snortrules-snapshot-2860.tar.gz.and I fine some error ,because my
>> snort still is v2.8.4.1,so I reinstall to 2.8.6.1. and the bad things
>> happen again .when I start up the snort,  error with Segmentation fault .
>>
>> i google it and some people say it's not match snort version and rules
>> version .is it snortrules-snapshot-2860.tar.gz must be used by 2.8.6.0
>> ? where can I download snort v2.8.6.0 ?





More information about the Snort-users mailing list