[Snort-users] Weird happenings

Russ Combs rcombs at ...1935...
Mon Apr 19 10:44:52 EDT 2010


This one came up before ... try adding this line to the inline.c includes:

#include <netinet/ether.h>

Snort has to work around a broken include.

Russ

On Mon, Apr 19, 2010 at 8:43 AM, <redwookie at ...11827...> wrote:

> I had set-up a Snort box running on RHEL 5.4 and all was good. Now it is a
> few weeks alter, and I am not sure what happened but I went to check the
> Snort and it was not running. When I tried to restart, I go the error:
> "-bash: snort: command not found". Not knowing what could've happened,
> because all the files and configs and what-not are where I expect them to
> be. So I tried to recompile (make distclean, ./configure --enable-sourcefire
> --enable-reload --enable-inline), thinking a recent RHEL update may have
> messed things up, and during the make I get the following:
> inline.c: In function âRejectLayer2â:
> inline.c:591: error: dereferencing pointer to incomplete type
> make[3]: *** [inline.o] Error 1
> HUH? Any ideas on what's going on here and how do i fix this so I can get
> this back online?
> V/r,
> Erik
>
> ------------------------------------------------------------------------------
> Download Intel® Parallel Studio Eval
> Try the new software tools for yourself. Speed compiling, find bugs
> proactively, and fine-tune applications for parallel performance.
> See why Intel Parallel Studio got high marks during beta.
> http://p.sf.net/sfu/intel-sw-dev
> _______________________________________________
> Snort-users mailing list
> Snort-users at lists.sourceforge.net
> Go to this URL to change user options or unsubscribe:
> https://lists.sourceforge.net/lists/listinfo/snort-users
> Snort-users list archive:
> http://www.geocrawler.com/redir-sf.php3?list=snort-users
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.snort.org/pipermail/snort-users/attachments/20100419/b50266a7/attachment.html>


More information about the Snort-users mailing list