[Snort-users] How to get dynamicdetection working

Russell Fulton r.fulton at ...3809...
Tue Apr 28 19:47:52 EDT 2009


I have just worked through compiling the rules on another machine with  
a brand new copy of 2.8.4.1 and still get it.

Apr 29 11:33:38 monitor-dmzo snort: FATAL ERROR: Dynamic detection  
lib /usr/local/lib/snort_dynamicrules/lib_sfdynamic_example_rule.so  
1.0 isn't compatible wi
th the current dynamic engine library /usr/local/lib/ 
snort_dynamicengine/libsf_engine.so 1.10. The dynamic detection lib is  
compiled with an older version of the dynamic engine.

After some stuffing around I did a rm lib_sfdynamic_example_rule.so*  
and everything burst into life.

It would appear that when you install snort it installs these bad  
libraries :(

Russell






More information about the Snort-users mailing list