[Snort-users] Snort 2.8.4 Beta - inline still not working on 64 bit have to use svn

Will Metcalf william.metcalf at ...11827...
Wed Oct 15 11:45:46 EDT 2008


snort-inline uses a newer version of libnet 1.1.x for the
reset/unreachable code...  I haven't had time to look into the NFQUEUE
issue with snort-inline on your recent kernel...  I can't speak to why
the SF guy's are still using the old version of libnet.

Regards,

Will

On Wed, Oct 15, 2008 at 10:02 AM, Morgan Cox <morgancoxuk at ...11827...> wrote:
> hi.
>
> Inline mode seems not possible on a 64bit system due to libnet
>
> If I manage to compile it using the non svn snort it segfaults when trying
> -Q to activate inline.  (using now kernel 2.6.27) however the snort-inline
> svn works fine with same kernel...
>
> I've tried to compile on mutiple systems - all 32bit ones work - ubuntu,
> fedora, all 64bit versions segfault.
>
> I'm pretty sure its related to the very very old version of libnet that
> snort (non snv) relies on for inline mode - is this lightly to be the case
> ?
>
> If so when is snort going to the more recent version of libnet ? The one it
> uses just doesn't work in a 64bit system and is about 4 years old .
>
> cheers
>
>
> -------------------------------------------------------------------------
> This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
> Build the coolest Linux based applications with Moblin SDK & win great
> prizes
> Grand prize is a trip for two to an Open Source event anywhere in the world
> http://moblin-contest.org/redirect.php?banner_id=100&url=/
> _______________________________________________
> Snort-users mailing list
> Snort-users at lists.sourceforge.net
> Go to this URL to change user options or unsubscribe:
> https://lists.sourceforge.net/lists/listinfo/snort-users
> Snort-users list archive:
> http://www.geocrawler.com/redir-sf.php3?list=snort-users
>




More information about the Snort-users mailing list