[Snort-users] Snort 2.8.4 Beta - inline still not working on 64 bit have to use svn

Morgan Cox morgancoxuk at ...11827...
Wed Oct 15 11:02:45 EDT 2008


hi.

Inline mode seems not possible on a 64bit system due to libnet

If I manage to compile it using the non svn snort it segfaults when trying
-Q to activate inline.  (using now kernel 2.6.27) however the snort-inline
svn works fine with same kernel...

I've tried to compile on mutiple systems - all 32bit ones work - ubuntu,
fedora, all 64bit versions segfault.

I'm pretty sure its related to the very very old version of libnet that
snort (non snv) relies on for inline mode - is this lightly to be the case
?

If so when is snort going to the more recent version of libnet ? The one it
uses just doesn't work in a 64bit system and is about 4 years old .

cheers
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.snort.org/pipermail/snort-users/attachments/20081015/9b68aab8/attachment.html>


More information about the Snort-users mailing list