[Snort-users] MacOSX bus error, snort-2.8.3.1 install

James Lay jlay at ...13475...
Tue Dec 30 08:50:17 EST 2008


On 12/29/08 8:03 PM, "John Kraus" <johnkraus3 at ...11827...> wrote:

> I keep getting a bus error on my MacOSX after installing Snort-2.8.3.1 and
> running in IDS mode, despite having followed, as best I can, the installation
> instructions, previous posts to this list, and other advice pertaining to this
> problem.
> 
> <snip>
> 
> Loading dynamic engine
> /usr/local/lib/snort_dynamicengine/libsf_engine.dylib... done
> Loading dynamic preprocessor library
> /usr/local/lib/snort_dynamicpreprocessor/libsf_dcerpc_preproc.dylib... done
> Loading dynamic preprocessor library
> /usr/local/lib/snort_dynamicpreprocessor/libsf_dns_preproc.dylib... done
> Loading dynamic preprocessor library
> /usr/local/lib/snort_dynamicpreprocessor/libsf_ftptelnet_preproc.dylib... done
> Loading dynamic preprocessor library
> /usr/local/lib/snort_dynamicpreprocessor/libsf_smtp_preproc.dylib... done
> Loading dynamic preprocessor library
> /usr/local/lib/snort_dynamicpreprocessor/libsf_ssh_preproc.dylib... done
> Bus error
> 
> I would be grateful for any suggestions on solving the bus error problem.
> Thanks,
> 


Did you do:

export LD_TWOLEVEL_NAMESPACE=1
export MACOSX_DEPLOYMENT_TARGET=10.5


Before configuring?  I had the same issue and this fixed that.

James
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.snort.org/pipermail/snort-users/attachments/20081230/7d967078/attachment.html>


More information about the Snort-users mailing list