[Snort-users] Snort on Mac OS X 10.2.8: Which version of Snort can I use?

Ian Masters ian at ...12163...
Mon Dec 22 03:17:53 EST 2008


Nerijus, Keith, Joel

Thanks for the replies and helpful information

> Read the INSTALL file till the end. It has some tips for building
> snort under OS X.

Thanks. I've now done that. I tried adding the extra commands:
glibtoolize --force
aclocal -I m4
autoheader
automake --add-missing --copy
autoconf
$ export LD_TWOLEVEL_NAMESPACE=1

but the decode.h error still appears.

> $ export LD_TWOLEVEL_NAMESPACE=1
> $ export MACOSX_DEPLOYMENT_TARGET=10.5  -(change 10.5 to your OS version)

That didn't make any difference either.

> 10.2.8?  You can't upgrade beyond that?  That's not even supported by
> Apple anymore, afaik.  I know we support 10.4 and 10.5 with Snort.

Unfortunately upgrading is unlikely. If it's impossible to run snort
2.8.3.1 on OSX 10.2.8, that's OK. I just need to know so that I can
think about other options.

If anyone from the ML or Sourcefire can confirm that, it would be very
useful.

Thanks people for the help. Much appreciated.

Ian






More information about the Snort-users mailing list