[Snort-users] Snort on Mac OS X 10.2.8: Which version of Snort can I use?

Joel Esler eslerj at ...11827...
Thu Dec 18 11:00:03 EST 2008


On Dec 18, 2008, at 12:19 AM, Ian Masters allegedly wrote:

> Hello again,
>
> I have a question for any Mac snort users.
>
> I'm trying to update snort from v2.3.2 to v2.8.3.2 on a couple of OS
> XServes which are version 10.2.8 and I'm getting the following  
> 'make' error:
>
> <snip>
> ../src/output-plugins -I../../src/detection-plugins
> -I../../src/dynamic-plugins -I../../src/preprocessors
> -I../../src/preprocessors/flow -I../../src/preprocessors/portscan
> -I../../src/preprocessors/flow/int-snort
> -I../../src/preprocessors/HttpInspect/include
> -I../../src/preprocessors/Stream5 -I../../src/target-based
> -I/usr/include/mysql -DENABLE_MYSQL  -g -O2 -Wall -DDYNAMIC_PLUGIN
> -DDETECTION_OPTION_TREE -c sfhashfcn.c
> ../../src/decode.h:740: undefined type, found `uint32_t'
> <snip>
>
> a lot more decode.h errors follow.
>
> Can any Mac users tell me either
> 1. How to solve the above or
> 2. What is the most recent snort version that will run on OSX 10.2.8

10.2.8?  You can't upgrade beyond that?  That's not even supported by  
Apple anymore, afaik.  I know we support 10.4 and 10.5 with Snort.

In your Snort tarball, look in the doc/ directory at the "INSTALL"  
file.  There are some OSX specific commands in there.

Joel




More information about the Snort-users mailing list