[Snort-users] Snort start error: [unknown rule type: dynamicpreprocessor]

Aaron Giuoco agiuoco at ...131...
Fri Oct 20 16:10:09 EDT 2006


Nope.  Still getting the same error message.

ERROR: /etc/snort/snort.conf(184) => unknown rule
type: dynamicpreprocessor

It errors out like it can't find the dynamic
preprocessor files or something.  This is really
strange.

AG

--- Justin Heath <justin.heath at ...11827...> wrote:

> ./configure --prefix=wherever --enable-dynamicplugin
> && make && make install
> cp -r etc wherever
> edit snort.conf to point to the correct location of
> the dynamicpreprocessors
> lib directory and change the path for dynamicengine
> to point to the
> dynamicengine file itself.
> 
> If you are using FreeBSD, OpenBSD or OS X look at
> the INSTALL guide in the
> doc directory of the source tarball for specific
> instructions for those
> platforms.
> 
> You can also just use the command line switches
> --dynamic preprocessor-lib,
> --dynamic preprocessor-lib-dir and
> --dynamic-engine-lib.
> 
> 
> On 10/20/06, Aaron Giuoco <agiuoco at ...131...> wrote:
> >
> > No, the paths are good.  I tried pointing the
> .conf
> > file to the actual files instead of the directory
> and
> > still got the same error message.
> >
> > When I comment out the dynamicpreprocessor lines
> and
> > the associated preprocessors further down in the
> .conf
> > file, Snort starts just fine.  I can't seem to get
> it
> > to work with the dynamic preprocessors.
> >
> > AG
> >
> > --- Justin Heath <justin.heath at ...11827...> wrote:
> >
> > > Check the paths in snort.conf for
> > > dynamicpreprocessors and dynamicengine.
> > >
> > > On 10/20/06, Aaron Giuoco <agiuoco at ...131...>
> wrote:
> > > >
> > > > I am using Snort 2.6.0.2 (build 85).  I am
> trying
> > > to
> > > > run snort with the following command line
> options:
> > > >
> > > > snort -c /etc/snort/snort.conf
> > > >
> > > > When do, I get the error message:
> > > >
> > > > ERROR: /etc/snort/snort.conf(184) => unknown
> rule
> > > > type: dynamicpreprocessor
> > > >
> > > > I have compiled snort from the tar package
> with
> > > the
> > > > --enable-dynamicplugin option.  Any idea why
> am
> > > > getting this error message?  Thanks
> > > >
> > > > AG
> > > >
> > > >
> __________________________________________________
> > > > Do You Yahoo!?
> > > > Tired of spam?  Yahoo! Mail has the best spam
> > > protection around
> > > > http://mail.yahoo.com
> > > >
> > > >
> > >
> >
>
-------------------------------------------------------------------------
> > > > Using Tomcat but need to do more? Need to
> support
> > > web services, security?
> > > > Get stuff done quickly with pre-integrated
> > > technology to make your job
> > > > easier
> > > > Download IBM WebSphere Application Server
> v.1.0.1
> > > based on Apache Geronimo
> > > >
> > >
> >
>
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
> > > >
> _______________________________________________
> > > > Snort-users mailing list
> > > > Snort-users at lists.sourceforge.net
> > > > Go to this URL to change user options or
> > > unsubscribe:
> > > >
> > >
> >
>
https://lists.sourceforge.net/lists/listinfo/snort-users
> > > > Snort-users list archive:
> > > >
> > >
> >
>
http://www.geocrawler.com/redir-sf.php3?list=snort-users
> > > >
> > >
> >
> >
> > __________________________________________________
> > Do You Yahoo!?
> > Tired of spam?  Yahoo! Mail has the best spam
> protection around
> > http://mail.yahoo.com
> >
> 


__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 




More information about the Snort-users mailing list