[Snort-users] Snort-2.4.4/Snortsam problem

John Hally JHally at ...5637...
Mon Jun 5 10:43:53 EDT 2006


Found it!

Need to run the autoconf commands

aclocal
autoheader
automake --add-missing
autoconf

 after copying the libprelude.m4 file to /usr/share/aclocal.


Posting this in case someone else ran into the same issue.

Thanks!

_____________________________________________
From: John Hally 
Sent: Monday, June 05, 2006 9:51 AM
To: snort-users at lists.sourceforge.net
Subject: Snort-2.4.4/Snortsam problem

Hello all,

I'm trying to compile in the snortsam patch into snort-2.4.4 and run into a
problem.  I get the following msg:

./configure: line 7760: syntax error near unexpected token `0.9.0,'
./configure: line 7760: `      AM_PATH_LIBPRELUDE(0.9.0, use_prelude=yes,
use_prelude=no)'

I found a thread that said I needed to copy the m4/libprelude.m4 file to
/usr/share/aclocal, which I did and still get the same error.  Anyone else
run into this and found a way around it?

Thanks!



Configure output:

./configure --with-libpcap-includes=/usr/local/libpcap-0.9.4-ring/include
--with-libpcap-libraries=/usr/local/libpcap-0.9.4-ring/lib
--prefix=/usr/local/snort-2.4.4-Ring3-Sam --enable-perfmonitor
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking for style of include used by make... GNU
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking dependency style of gcc... gcc3
checking for ranlib... ranlib
checking for gcc... (cached) gcc
checking whether we are using the GNU C compiler... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking for gcc option to accept ANSI C... (cached) none needed
checking dependency style of gcc... (cached) gcc3
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking whether byte ordering is bigendian... no
checking for sparc alignment... no
checking how to run the C preprocessor... gcc -E
checking for egrep... grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for strings.h... (cached) yes
checking for string.h... (cached) yes
checking for stdlib.h... (cached) yes
checking for unistd.h... (cached) yes
checking sys/sockio.h usability... no
checking sys/sockio.h presence... no
checking for sys/sockio.h... no
checking paths.h usability... yes
checking paths.h presence... yes
checking for paths.h... yes
checking for inet_ntoa in -lnsl... yes
checking for socket in -lsocket... no
checking whether printf must be declared... no
checking whether fprintf must be declared... no
checking whether syslog must be declared... no
checking whether puts must be declared... no
checking whether fputs must be declared... no
checking whether fputc must be declared... no
checking whether fopen must be declared... no
checking whether fclose must be declared... no
checking whether fwrite must be declared... no
checking whether fflush must be declared... no
checking whether getopt must be declared... no
checking whether bzero must be declared... no
checking whether bcopy must be declared... no
checking whether memset must be declared... no
checking whether strtol must be declared... no
checking whether strcasecmp must be declared... no
checking whether strncasecmp must be declared... no
checking whether strerror must be declared... no
checking whether perror must be declared... no
checking whether socket must be declared... no
checking whether sendto must be declared... no
checking whether vsnprintf must be declared... no
checking whether snprintf must be declared... no
checking whether strtoul must be declared... no
checking for snprintf... yes
checking for strlcpy... no
checking for strlcat... no
checking for strerror... yes
checking for __FUNCTION__... yes
checking for floor in -lm... yes
checking for pcap_datalink in -lpcap... yes
checking pcre.h usability... yes
checking pcre.h presence... yes
checking for pcre.h... yes
checking for pcre_compile in -lpcre... yes
./configure: line 7760: syntax error near unexpected token `0.9.0,'
./configure: line 7760: `      AM_PATH_LIBPRELUDE(0.9.0, use_prelude=yes,
use_prelude=no)'
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.snort.org/pipermail/snort-users/attachments/20060605/22d5dcd9/attachment.html>


More information about the Snort-users mailing list