[Snort-users] Help with installing on RH4 R2

Dirk Geschke dirk at ...10648...
Wed Feb 22 00:59:00 EST 2006


Hi Eric,

> Hi, I'm trying to install Snort on RH ES4 R2 with the base RPMs from the CDs
> following the directions provided by Patrick Harper. 
> 
> Everything runs great through the ./configure --with-mysql
> 
> When I run make, I am getting the following error:
> 
> /usr/bin/ld: cannot find -lmysqlclient
> collect2: ld returned 1 exit status
> make[3]: *** [snort] Error 1
> 
> Has anyone run into this before? Any suggestions?

the problem is obviously, you either have not installed the
libmysqlclient library or you have installed it at a location
where the linker can not find it.

You can use the LDFLAGS envrionment variable with configure
to point to the correct location, e.g.:

LDFLAGS=-L/usr/local/mysql/lib/mysql ./configure --with-mysql

If it is a dynamic library you should also try to add the
search path to the executable. 

Best regards

Dirk




More information about the Snort-users mailing list