[Snort-users] Patching Snort 2.4.2 with ClamAV Errors

Will Metcalf william.metcalf at ...11827...
Tue Oct 4 13:46:10 EDT 2005


Yeah I got the same thing on sarge, I know it is kind of a crappy fix
but if you are not using prelude just Nuke the following from
configure.in and run autoreconf -f.  Haven't had time to get into it,
been super swamped at my paying job, but that should fix your problem.

Regards,

Will

dnl
dnl Prelude support
dnl
AC_ARG_ENABLE(prelude,
[  --enable-prelude     Enable Prelude Hybrid IDS support],
                want_prelude="$enableval", want_prelude=no)
if test x$want_prelude = xyes; then
      AM_PATH_LIBPRELUDE(0.9.0, use_prelude=yes, use_prelude=no)
      if test "$use_prelude" = "yes"; then
              LDFLAGS="${LDFLAGS} ${LIBPRELUDE_LDFLAGS}"
              LIBS="$LIBS ${LIBPRELUDE_LIBS}"
              CFLAGS="$CFLAGS ${LIBPRELUDE_PTHREAD_CFLAGS}"
              AC_DEFINE(HAVE_LIBPRELUDE,, Define whether Prelude
support is enabled)
      fi
fi


On 10/4/05, Bill Warren <bwarren at ...12173...> wrote:
> I just downloaded the latest everything and I am getting stuck.  Any
> ideas?  I am running Debian Sarge with all the updates.
>
> tar -zxvf snort-2.4.2.tar.gz
> cp snort-2.4.2-clamonly.diff snort-2.4.2
> cd snort-2.4.2
> patch -p 1 < snort-2.4.2-clamonly.diff
>
> patching file configure.in
> Hunk #1 succeeded at 859 with fuzz 2.
> patching file src/debug.h
> patching file src/generators.h
> patching file src/plugbase.c
> patching file src/preprocessors/Makefile.am
> patching file src/preprocessors/spp_clamav.c
> patching file src/preprocessors/spp_clamav.h
>
> autoreconf -f
>
> configure.in:169: warning: underquoted definition of SN_CHECK_DECL
>  run info '(automake)Extending aclocal'
>  or see http://sources.redhat.com/automake/automake.html#Extending-aclocal
> configure.in:202: warning: underquoted definition of SN_CHECK_DECLS
> configure.in:298: warning: underquoted definition of FAIL_MESSAGE
> aclocal:configure.in:675: warning: macro `AM_PATH_LIBPRELUDE' not found
> in library
> configure.in:675: error: possibly undefined macro: AM_PATH_LIBPRELUDE
>      If this token and others are legitimate, please use m4_pattern_allow.
>      See the Autoconf documentation.
> autoreconf: /usr/bin/autoconf failed with exit status: 1
>
>
>
>




More information about the Snort-users mailing list