[Snort-users] why old libnet?

Florin Andrei florin at ...13138...
Mon Mar 28 11:00:55 EST 2005


On Mon, 2005-03-28 at 12:16 -0500, Matt Kettler wrote:
> Florin Andrei wrote:
> 
> >What is the reason why Snort can only use the old, deprecated,
> >libnet-1.0.x?
> 
> Really, the only part of snort that uses libnet is flexresp. If you're
> not using flexresp, snort shouldn't be looking for libnet.
> As for flexresp itself, it's getting to be a bit on the "aged" side.
> I also think that while Flexresp is useful, people believe it to be more
> useful than it is. Flexresp is really pretty limited.

My thoughts exactly, but it looks like libnet is also required by --
enable-inline
If i don't put in --enable-inline, it does not require libnet. If i do
put it in, it requires libnet.

-- 
Florin Andrei

http://florin.myip.org/





More information about the Snort-users mailing list