[Snort-users] Starting Snort Errors-Fedora3

Michael Graybill mgraybill at ...13139...
Mon Mar 21 05:46:54 EST 2005


I to follwed Patricks doc and I tried the T switch to check everything
and I get this below. I need to know if this is actually going into my
database or not because Base is not showing anything.

[root at ...13192... ~]# snort -i eth0 -c /etc/snort/snort.conf -T
Running in IDS mode

Initializing Network Interface eth0

        --== Initializing Snort ==--
Initializing Output Plugins!
Decoding Ethernet on interface eth0
Initializing Preprocessors!
Initializing Plug-ins!
Parsing Rules file /etc/snort/snort.conf

+++++++++++++++++++++++++++++++++++++++++++++++++++
Initializing rule chains...
,-----------[Flow Config]----------------------
| Stats Interval:  0
| Hash Method:     2
| Memcap:          10485760
| Rows  :          4099
| Overhead Bytes:  16400(%0.16)
`----------------------------------------------
No arguments to frag2 directive, setting defaults to:
    Fragment timeout: 60 seconds
    Fragment memory cap: 4194304 bytes
    Fragment min_ttl:   0
    Fragment ttl_limit: 5
    Fragment Problems: 0
    Self preservation threshold: 500
    Self preservation period: 90
    Suspend threshold: 1000
    Suspend period: 30
Stream4 config:
    Stateful inspection: ACTIVE
    Session statistics: INACTIVE
    Session timeout: 30 seconds
    Session memory cap: 8388608 bytes
    State alerts: INACTIVE
    Evasion alerts: INACTIVE
    Scan alerts: INACTIVE
    Log Flushed Streams: INACTIVE
    MinTTL: 1
    TTL Limit: 5
    Async Link: 0
    State Protection: 0
    Self preservation threshold: 50
    Self preservation period: 90
    Suspend threshold: 200
    Suspend period: 30
    Enforce TCP State: INACTIVE
    Midstream Drop Alerts: INACTIVE

Stream4_reassemble config:
    Server reassembly: INACTIVE
    Client reassembly: ACTIVE
    Reassembler alerts: ACTIVE
    Zero out flushed packets: INACTIVE
    flush_data_diff_size: 500
    Ports: 21 23 25 53 80 110 111 143 513 1433
    Emergency Ports: 21 23 25 53 80 110 111 143 513 1433
HttpInspect Config:
    GLOBAL CONFIG
      Max Pipeline Requests:    0
      Inspection Type:          STATELESS
      Detect Proxy Usage:       NO
      IIS Unicode Map Filename: /etc/snort/unicode.map
      IIS Unicode Map Codepage: 1252
    DEFAULT SERVER CONFIG:
      Ports: 80 8080 8180
      Flow Depth: 300
      Max Chunk Length: 500000
      Inspect Pipeline Requests: YES
      URI Discovery Strict Mode: NO
      Allow Proxy Usage: NO
      Disable Alerting: NO
      Oversize Dir Length: 500
      Only inspect URI: NO
      Ascii: YES alert: NO
      Double Decoding: YES alert: YES
      %U Encoding: YES alert: YES
      Bare Byte: YES alert: YES
      Base36: OFF
      UTF 8: OFF
      IIS Unicode: YES alert: YES
      Multiple Slash: YES alert: NO
      IIS Backslash: YES alert: NO
      Directory Traversal: YES alert: NO
      Web Root Traversal: YES alert: YES
      Apache WhiteSpace: YES alert: NO
      IIS Delimiter: YES alert: NO
      IIS Unicode Map: GLOBAL IIS UNICODE MAP CONFIG
      Non-RFC Compliant Characters: NONE
rpc_decode arguments:
    Ports to decode RPC on: 111 32771
    alert_fragments: INACTIVE
    alert_large_fragments: ACTIVE
    alert_incomplete: ACTIVE
    alert_multiple_requests: ACTIVE
telnet_decode arguments:
    Ports to decode telnet on: 21 23 25 119
Portscan Detection Config:
    Detect Protocols:  TCP UDP ICMP IP
    Detect Scan Type:  portscan portsweep decoy_portscan
distributed_portscan
    Sensitivity Level: Low
    Memcap (in bytes): 10000000
    Number of Nodes:   36900

database: compiled support for ( mysql )
database: configured to use mysql
database:          user = snort
database: password is set
database: database name = snort
database:          host = localhost
database:   sensor name = 192.168.4.200
database:     sensor id = 1
database: schema version = 106
database: using the "log" facility
2180 Snort rules read...
2180 Option Chains linked into 190 Chain Headers
0 Dynamic rules
+++++++++++++++++++++++++++++++++++++++++++++++++++

Warning: flowbits key 'realplayer.playlist' is checked but not ever set.

+-----------------------[thresholding-config]---------------------------
-------
| memory-cap : 1048576 bytes
+-----------------------[thresholding-global]---------------------------
-------
| none
+-----------------------[thresholding-local]----------------------------
-------
| gen-id=1      sig-id=2495      type=Both       tracking=dst count=20
seconds=60
| gen-id=1      sig-id=2523      type=Both       tracking=dst count=10
seconds=10
| gen-id=1      sig-id=2924       type=Threshold tracking=src count=10
seconds=60
| gen-id=1      sig-id=2923       type=Threshold tracking=src count=10
seconds=60
| gen-id=1      sig-id=2496      type=Both       tracking=dst count=20
seconds=60
| gen-id=1      sig-id=2494      type=Both       tracking=dst count=20
seconds=60
| gen-id=1      sig-id=2275       type=Threshold tracking=dst count=5
seconds=60
+-----------------------[suppression]-----------------------------------
-------
------------------------------------------------------------------------
-------
Rule application order: ->activation->dynamic->alert->pass->log
Log directory = /var/log/snort

        --== Initialization Complete ==--

   ,,_     -*> Snort! <*-
  o"  )~   Version 2.3.0RC2 (Build 9)
   ''''    By Martin Roesch & The Snort Team:
http://www.snort.org/team.html
           (C) Copyright 1998-2004 Sourcefire Inc, et al.


Snort sucessfully loaded all rules and checked all rule chains!
Final Flow Statistics
,----[ FLOWCACHE STATS ]----------
Memcap: 10485760 Overhead Bytes 16400 used(%0.156403)/blocks (16400/1)
Overhead blocks: 1 Could Hold: (0)
IPV4 count: 0 frees: 0 low_time: 0, high_time: 0, diff: 0h:00:00s
    finds: 0 reversed: 0(%0.000000)
    find_sucess: 0 find_fail: 0 percent_success: (%0.000000) new_flows:
0
database: Closing connection to database ""
Snort exiting
[root at ...13192... ~]#

TIA,

Mike

-----Original Message-----
From: snort-users-admin at lists.sourceforge.net
[mailto:snort-users-admin at lists.sourceforge.net] On Behalf Of Paul
Schmehl
Sent: Friday, March 11, 2005 9:31 AM
To: Mark Sargent; snort-users at lists.sourceforge.net
Subject: Re: [Snort-users] Starting Snort Errors-Fedora3

--On Friday, March 11, 2005 04:57:25 PM +0900 Mark Sargent 
<powderkeg at ...11462...> wrote:

> Hi All, am a Linux user, Fedora3. Rather new to it, and snort as well.
I
> have installed snort and have apache/mysql running. Am following the
> tutorial for FC2 from Patrick S. Harper. I just tried starting snort
and
> got the following,
>
>  [root at ...274... snort]# snort -i 192.168.0.12 -dev

This is incorrect.  The -i switch is used to designate the *device* you 
want to sniff on, *not* the IP address.

It *should* be this:
snort -i eth0

Try using the -T switch to verify that everything is correct in your
setup.
snort -i eth0 -c /etc/snort/snort.conf -T

"-dev" means:
-d         Dump the Application Layer
-e         Display the second layer header info
-v         Be verbose

Is that what you want?

Paul Schmehl (pauls at ...6838...)
Adjunct Information Security Officer
The University of Texas at Dallas
AVIEN Founding Member
http://www.utdallas.edu


-------------------------------------------------------
SF email is sponsored by - The IT Product Guide
Read honest & candid reviews on hundreds of IT Products from real users.
Discover which products truly live up to the hype. Start reading now.
http://ads.osdn.com/?ad_id=6595&alloc_id=14396&op=click
_______________________________________________
Snort-users mailing list
Snort-users at lists.sourceforge.net
Go to this URL to change user options or unsubscribe:
https://lists.sourceforge.net/lists/listinfo/snort-users
Snort-users list archive:
http://www.geocrawler.com/redir-sf.php3?list=snort-users




More information about the Snort-users mailing list