[Snort-users] problems with barnyard, snort and mysql

Kevin Smith kjsmith at ...13166...
Tue Mar 15 08:25:31 EST 2005


Hey Marek,

Yes, I tried that fix as well. Still recieved the same error. Could it 
be the version of Perl I am running? I am starting to think that it is 
the configure script, but I don't see anything in there that wouldn't 
allow it to work. I was able to get it installed on my home machine 
without any problems(same install of mempis), I am going to try the 
configure script at home on my machine in the office. I will let you 
guys know what is up.

Kevin

Marek Simon wrote:

>I have similar problem on OBSD and I was found this advice:
>
>-----cut----
>original configure script:
>
>  LIBS="${LIBS} -lz -lssl -lmysqlclient"
>
>modified configure script:
>
>  LIBS="${LIBS} -lz -lssl -lcrypto -lmysqlclient"
>-----cut----
>
>it work for me.
>Marek
>
>
>
>On Sat, 2005-03-12 at 10:12 -0500, Kevin Smith wrote:
>  
>
>>Okay, I did notice I forgot to install dev files for mysql, once I did
>>that I ran ./configure --enable-mysql, however then it error or the
>>library files. 
>>
>>checking for /usr/include/mysql/mysql.h... yes
>>checking for mysql_real_connect in -lmysqlclient... no
>>**********************************************
>>  ERROR: unable to find mysqlclient library
>>  checked in the following places
>>        /usr/lib/
>>**********************************************
>>    
>>
>
>  
>




More information about the Snort-users mailing list